Speedplay cleat problems

Discuss light weight issues concerning road bikes & parts.
Post Reply
raggi
Posts: 61
Joined: Thu Mar 02, 2017 2:43 pm

by raggi

Hi, might be a rookie problem on my end, but here goes.

Ordered a pair of speedplay pedals+cleats and I'm having a hardest time getting the cleats fitted to my S-works 6 shoes..

Once the base plate is on, with what I think is the correct shims (6F/6R), there is no way that I can screw the bottom plate to the base plate, probably due to the base plate flexing?

I can screw the bottom plate to the base plate just fine before attaching the base plate to the shoe.

Anyone have an idea of what it could be? Wrong base plate placement on the shoes? Do I need different shims other than the ones that were supplied with the cleats?

rlanger
Posts: 129
Joined: Sun Oct 02, 2016 11:53 am

by rlanger

There are tiny little nuts that are inside the holes of the base plate that the cleat screws into.

First, make sure that the nuts are there (they can fall out). And second, make sure that they are pushed all the way in, i.e. closest to the end of the baseplate that the cleat screws into.

Give that a shot.

by Weenie


raggi
Posts: 61
Joined: Thu Mar 02, 2017 2:43 pm

by raggi

Thanks, ill take a look at that, but wouldnt that also give me problems when the base plate isnt attached to the shoe?

coresare
Posts: 104
Joined: Thu Jun 18, 2015 8:19 am

by coresare

When you use the shims, does the curve of the baseplate match the shoe's curve perfectly?

wilwil
Posts: 365
Joined: Thu Sep 23, 2010 5:47 pm

by wilwil

You may have to use the tiny shims to get a perfect curve

rlanger
Posts: 129
Joined: Sun Oct 02, 2016 11:53 am

by rlanger

raggi wrote:
Wed May 01, 2019 3:07 pm
Thanks, ill take a look at that, but wouldnt that also give me problems when the base plate isnt attached to the shoe?
That's true it might, but it's still worth a shot.

by Weenie


Whit3Nitro
Posts: 1
Joined: Wed May 01, 2019 3:58 pm

by Whit3Nitro

Hey, I had this problem with my sidi shoes I bought the other day. The base plate had flexed wich meant it didn’t line up with the cleat plate. Try screwing in each screw a few turns at a time. Worked for me.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post