Di2 Junction Box (SM-EW90-A) constantly blinking green?

Discuss light weight issues concerning road bikes & parts.
Post Reply
jbattermann
Posts: 47
Joined: Mon Feb 20, 2017 10:47 pm

by jbattermann

Good evening,

I am currently building up a new Road/Gravel bike with a Di2 groupset.. well.. sort of (ST 9170 DI2 levers + 1 x XT Di2) and I am having a somewhat strange problem - the junction box (SM-EW90-A) has started to blink green.. constantly.. and it doesn't stop doing that.

I can connect to the groupset via the charger/usb-thingy & the E-Tube Windows application and the later detects the components - and while I am -in- the application and connected the blinking stops, but once I leave the application / settings it starts back doing it again.

And I am somewhat.. confused about what's going on.

Does anyone know what that's supposed to mean / how I can turn it off? The problem is - shifting doesn't work, nor can I enter i.e. wireless / bluetooth connection mode.. nor.. well.. do anything. All that worked out of the box but upon first connection via the mobile phone app it wanted to perform a firmware upgrade.. and ever since it's basically doing that.

Any ideas/suggestions are highly welcome!
-J

avispa
Posts: 275
Joined: Tue Mar 11, 2008 2:36 am

by avispa

Can you provide us the model number of the battery you are using?

There are some versions of the internal battery that may not be fully compatible with every setup.

There’s also a possibility that you may have to connect your setup with the Shimano SM-PCE1. The connector that allows you to plug in to the e-tube software on a computer and with it check individual components for errors.

For as great as the phone app is, it will not give you a complete error report of what is happening with your system.

by Weenie


jbattermann
Posts: 47
Joined: Mon Feb 20, 2017 10:47 pm

by jbattermann

Good morning @avipsa & thanks for the reply! The battery is a 'BT-DN110-A' one (see https://r2-bike.com/SHIMANO-Battery-Lit ... be-Project) which is supposed to be compatible with with all components.

In my case I 'fixed' it earlier today by unplugging everything one by one and back together and in particular after disconnecting and reconnecting the rear derailleur from the system everything is working normally again and the blinking has stopped now. Not sure what is/was actually causing it but that re-connect cycle fixed it.

avispa
Posts: 275
Joined: Tue Mar 11, 2008 2:36 am

by avispa

jbattermann wrote:
Wed Dec 26, 2018 11:35 am
Good morning @avipsa & thanks for the reply! The battery is a 'BT-DN110-A' one (see https://r2-bike.com/SHIMANO-Battery-Lit ... be-Project) which is supposed to be compatible with with all components.

In my case I 'fixed' it earlier today by unplugging everything one by one and back together and in particular after disconnecting and reconnecting the rear derailleur from the system everything is working normally again and the blinking has stopped now. Not sure what is/was actually causing it but that re-connect cycle fixed it.

Great to hear... I bet something was not connected securelly. It is a good idea to use the Shimano TL-EW02 Di2 Wire Connecting Installation Tool to plug the wires to the componets, rather than using just your fingers. It securely snaps everything...

jencvo
Posts: 80
Joined: Thu Oct 18, 2018 12:01 pm

by jencvo

jbattermann wrote:
Wed Dec 26, 2018 11:35 am
Good morning @avipsa & thanks for the reply! The battery is a 'BT-DN110-A' one (see https://r2-bike.com/SHIMANO-Battery-Lit ... be-Project) which is supposed to be compatible with with all components.

In my case I 'fixed' it earlier today by unplugging everything one by one and back together and in particular after disconnecting and reconnecting the rear derailleur from the system everything is working normally again and the blinking has stopped now. Not sure what is/was actually causing it but that re-connect cycle fixed it.
I ordered my Di2 groupset from R2 Bikes as well. All worked great when I connected all the wires, then I tried updating firmware via D Fly unit, shifting wouldn't work, the lights were blinking, etc. What fixed it was to download Shimano's app onto my computer and connect the computer to Di2 to run software upgrade and then it all got fixed and I've had zero problems since.

BdaGhisallo
Posts: 2324
Joined: Wed Mar 17, 2004 1:38 pm

by BdaGhisallo

jencvo wrote:
Thu Dec 27, 2018 11:56 am
jbattermann wrote:
Wed Dec 26, 2018 11:35 am
Good morning @avipsa & thanks for the reply! The battery is a 'BT-DN110-A' one (see https://r2-bike.com/SHIMANO-Battery-Lit ... be-Project) which is supposed to be compatible with with all components.

In my case I 'fixed' it earlier today by unplugging everything one by one and back together and in particular after disconnecting and reconnecting the rear derailleur from the system everything is working normally again and the blinking has stopped now. Not sure what is/was actually causing it but that re-connect cycle fixed it.
I ordered my Di2 groupset from R2 Bikes as well. All worked great when I connected all the wires, then I tried updating firmware via D Fly unit, shifting wouldn't work, the lights were blinking, etc. What fixed it was to download Shimano's app onto my computer and connect the computer to Di2 to run software upgrade and then it all got fixed and I've had zero problems since.
Most of the time when I read of problems like this the one thing they have in common is people updating the DI2 components via bluetooth and the app. I don't know why that is. And very often, the solution is to do the updating with the PC software and a direct wire link to the computer.

by Weenie


Post Reply
  • Similar Topics
    Replies
    Views
    Last post