Page 7 of 9

Re: Sram eTap rear derailleur sporadically stops shifting - then performs all queued shifts at once?

Posted: Sat Aug 17, 2019 2:41 pm
by northshore
XCProMD wrote:
Mon Aug 12, 2019 8:15 pm

The sealing in those can be ruined by solvents, for instance.
Would it be bad practice to use a spray lubricant on your derailleurs then, as the carrier is a solvent?

Re: Sram eTap rear derailleur sporadically stops shifting - then performs all queued shifts at once?

Posted: Sun Aug 18, 2019 6:14 pm
by XCProMD
Definitely yes.


Skickat från min iPhone med Tapatalk

Re: Sram eTap rear derailleur sporadically stops shifting - then performs all queued shifts at once?

Posted: Sun Aug 18, 2019 6:14 pm
by Weenie

Re: Sram eTap rear derailleur sporadically stops shifting - then performs all queued shifts at once?

Posted: Sun Aug 18, 2019 6:20 pm
by XCProMD
Nickldn wrote:
ChiZ01 wrote:
Sun Aug 11, 2019 10:17 pm
sfo423 wrote:
Sat Aug 03, 2019 11:17 pm
Should have stuck with Shimano.


Wise words
I was told by LBS that Shimano can usually fix electronic problems on Di2 and it is possible to disassemble these units. Not so for SRAM etap.

These issues have really put me off SRAM as a company. I really like electronic shifting, but next time I'll go for Di2.
Shimano will not disassemble anything. The servos in the derailleurs can be physically detached from the rest using some mechanical skills and good tools but Shimano will neither do it if you send your derailleurs in nor guarantee such a job from you or your LBS (the latter as any other maker anyway). Campag is the only make that will service servos but at a dear cost (you’re warned Image)

I don’t find SRAM eTap less reliable than Di2, falling batteries notwithstanding.


Skickat från min iPhone med Tapatalk

Re: Sram eTap rear derailleur sporadically stops shifting - then performs all queued shifts at once?

Posted: Tue Aug 20, 2019 11:31 pm
by Nickldn
XCProMD wrote:
Sun Aug 18, 2019 6:20 pm
Nickldn wrote:
ChiZ01 wrote:
Sun Aug 11, 2019 10:17 pm
sfo423 wrote:
Sat Aug 03, 2019 11:17 pm
Should have stuck with Shimano.


Wise words
I was told by LBS that Shimano can usually fix electronic problems on Di2 and it is possible to disassemble these units. Not so for SRAM etap.

These issues have really put me off SRAM as a company. I really like electronic shifting, but next time I'll go for Di2.
Shimano will not disassemble anything. The servos in the derailleurs can be physically detached from the rest using some mechanical skills and good tools but Shimano will neither do it if you send your derailleurs in nor guarantee such a job from you or your LBS (the latter as any other maker anyway). Campag is the only make that will service servos but at a dear cost (you’re warned Image)

I don’t find SRAM eTap less reliable than Di2, falling batteries notwithstanding.


Skickat från min iPhone med Tapatalk
It would be really interesting to see statistics on electronic groupset failure rates for SRAM, Shimano and Campi. Do they exist?

I'm going on what seems like a high number of posts on here and other forums about SRAM failures compared to Shimano failures vs. road bike electronic groupset sales. I'm guessing Di2 outsells etap significantly and etap outsells EPS.

Another issue is repairability. There's a new EU law coming in 2021 on minimum standards for repairable electronics and California along with many other US States has already passed some 'Right to Repair' laws.

I hope groupset manufacturers take note and make their products easier to fix.

Re: Sram eTap rear derailleur sporadically stops shifting - then performs all queued shifts at once?

Posted: Wed Aug 21, 2019 12:29 am
by UpFromOne
I truly feel bad for any cyclist with equipment issues, whether elecronic or mechanical.

However, there is an inherent beauty in purely mechanical components.
I do hope manual groupsets don't acquire vintage status for some time yet.

Re: Sram eTap rear derailleur sporadically stops shifting - then performs all queued shifts at once?

Posted: Wed Aug 21, 2019 4:40 pm
by XCProMD
I don’t think is possible to do such statistics without involving the manufacturers themselves, so short answer is no.

SRAM’s failures are related to falling batteries and this thing of the PU bushings (Igus, by the way) getting stuck. The electronics on the other hands seem to be pretty solid. Also the way the motor is connected makes for a trouble free system, even if the RD is bent, the action happens close to the upper pulley. I was worried at first for the gear reduction after the motor but so far it arena robust and well sealed.

Campag has problems with drained batteries in V1. Too long storage at low level. They also had water ingress issues around 2003 in prototype stage. Then it has been quiet, they seem to have made the correct decision with a higher voltage. Also the planetary worm drive and how it is connected to the parallelogram is a very robust design, but that was also due to be the first in patenting the derailleurs (1993).

With Di2 the problems are the potentiometers at the derailleurs, bent servo links and, subsequently or otherwise, battery drain. It’s nowhere as bad nowadays as with the 7970 system, but it’s still there.


Skickat från min iPhone med Tapatalk

Re: Sram eTap rear derailleur sporadically stops shifting - then performs all queued shifts at once?

Posted: Fri Aug 30, 2019 3:02 pm
by Jugi
XCProMD wrote:
Mon Aug 12, 2019 8:15 pm
It’s those pins. This is another X01, but you get the idea.
Please XCProMD, I'm trying to revive my RD and you're my only hope.

Got this far - circlips and underlying spacer plates removed from two pins. Removed B screw just to gain some working room. What's the next step?

Image

Can't see any surfaces for tools on either end. When pushing them with fingers or slight tool pressure from the circlips' side, it feels like they are connected or stuck at the parallelogram on the other side. Are the black ends of the pins covers that need to be pried off or what?

Image

Re: Sram eTap rear derailleur sporadically stops shifting - then performs all queued shifts at once?

Posted: Fri Aug 30, 2019 7:27 pm
by XCProMD
Just tap them out from top (circlip side) to bottom using something like a small (3 mm) screwdriver and a small nylon hammer.

The fact that the pin don’t slide off means that they’re probably stuck in the Iglidur PU bushings pressed in the RD body.

Hope that helps.


Skickat från min iPhone med Tapatalk

Re: Sram eTap rear derailleur sporadically stops shifting - then performs all queued shifts at once?

Posted: Sat Aug 31, 2019 1:18 pm
by XCProMD
Oh, by the way: There’s one of the pins that you can’t tap out. That one is mechanically connected to the reduction gears of the servo. But that one is not making the derailleur stuck.

I see in the first picture that you have already removed the rubber seals under the clips. Now the steel pins are snug fit through the Igus flanged bushings.


Skickat från min iPhone med Tapatalk

Re: Sram eTap rear derailleur sporadically stops shifting - then performs all queued shifts at once?

Posted: Sat Aug 31, 2019 1:41 pm
by XCProMD
Image

Let’s see if my limited posting skills can help:

In the pic you see the Igus bushing in a red marking. As you can see, it’s longer than the parallelogram link hole it’s inserted in. And it should spin freely around a O-ring like the one in the green marking at the same time that it spins around the metal pin that’s been tapped out for the picture (well, actually to make this derailleur return to the two smaller cogs, the spring couldn’t overcome the friction which is often the same problem the servo has in eTap derailleurs)

Clean everything and reassemble. Make sure beforehand that the pins spin freely in the bushings. If the seals look loose don’t worry as , as you see, they usually are after some months of use, especially if they have been sprayed with solvents or exposed to aggressive cleaning products.

It’s more important to keep everything spinning smoothly, even with some play. These RD are much tighter in their assembly than Shimano’s for example.


Skickat från min iPhone med Tapatalk

Re: Sram eTap rear derailleur sporadically stops shifting - then performs all queued shifts at once?

Posted: Thu Oct 24, 2019 7:57 pm
by Jugi
I haven't had much time to get into this, but now I have finally made some progress. And I'm starting to feel like the cause for sporadic jams might actually be a mechanical fault after all.

Before I achieved anything I used a couple of hours trying to "tap" the pins out like suggested. That didn't do much of anything. Finally, instead of tapping, I resorted to pressing them out. They have a pressfit fitting at one end and they really were properly stuck on the parallelogram. Weapon of choice on the right hand side:

Image

A tip for anyone attempting this: Depending on tools you use, it may be easier to remove the pins by opening up the parallelogram first (as in moving the servo into a desired position). If you do that, make sure to disconnect the cable leading from the electronics to the back side of the battery bracket. When the parallelogram gets removed and the main spring de-tensions, that cable may get snagged and left in tension.

The pins and circlips were surprisingly clean all things considered, and I didn't come across anything in the parallelogram that looked like the culprit. While I had those two pins out, I cycled the servo without the RD's spring tension resisting it. I didn't capture any jams in the video below, but it did jam even without any outside resistance. It was really hard to tell whether the servo "overshot" it's position and jammed because of that, or just encountered too much resistance and went into fail-safe.

Another tip: while doing this, don't cycle the gears all the way through as the servo's actuation arm will snag the cable.



After that session I didn't get back to it for a while, but still wanted to know what was up. Today I removed one of the pins and tried to remove that plastic cover over the servo, which is attached by screws. I tried to pry it off gently but didn't succeed. It turns out the electronics and the servo seem to be attached to that cover, so it can't be removed without detaching atleast the servo's actuation arm before that.

But, after putting it back together I discovered a change in symptoms. Before this session the jams seemed to happen at or after the midway point when going through the gears starting from hardest and ending to easiest. Now, they seemed to happen at the 2nd or 3rd click when starting from the hardest gear, and only when moving from harder to easier gears. Also, it doesn't seem to jam nearly as often as it did before.



While it did jam, I listened what was happening in silence and a faint clicking sound could be heard from the RD. It sounded like the servo was touching the reduction gear or something but then backed off. If you listen in really closely on that video, it can be heard at seconds 00:39-00:41.

As I was able to observe a clear change in the RD's behaviour, I'm starting to get slightly hopeful about reviving this thing. I decided to put the RD back on the bike while it's on the trainer, and test ride it for some time to see how frequently the jams happen in zwifting.

Re: Sram eTap rear derailleur sporadically stops shifting - then performs all queued shifts at once?

Posted: Thu Oct 24, 2019 9:46 pm
by XCProMD
Great post. I think it is definitely a mechanical problem in most cases. I have yet to come across:

1- An eTap derailleur that doesn’t improve after cleaning the parallelogram bushings

2- An eTap derailleur with partially non functioning electronics (as opposed to Di2 where the position potentiometer faults, for instance, are quite common)


Skickat från min iPhone med Tapatalk

Re: Sram eTap rear derailleur sporadically stops shifting - then performs all queued shifts at once?

Posted: Fri Feb 14, 2020 6:51 pm
by Jugi
Jugi wrote:
Thu Oct 24, 2019 7:57 pm
As I was able to observe a clear change in the RD's behaviour, I'm starting to get slightly hopeful about reviving this thing. I decided to put the RD back on the bike while it's on the trainer, and test ride it for some time to see how frequently the jams happen in zwifting.
As a follow up to this:

This particular rear derailleur has been ridden for 107 hours 27 minutes between Oct 24th - Feb 14th exclusively on Zwift. Riding time has consisted of mainly free riding (easy rides, workouts in free ride mode, segment hunting and races) and only a couple of ERG mode workouts, which of course do not necessitate many shifts at all. Tacx Neo (1gen) has been responsible of resisting me in my garage. The garage has stayed quite consistently between 0°C...+8°C during the winter. Shifts have been mainly single shifts, but every now and again I have used the shift burst (ie. descending from Watopia's Epic, as both sides of the mountain have short & sharp inclines when going down). Cassette and chain used have been the SRAM PG-1170 11-25 and SRAM Red 22.

During this time period, I made a remark of only one shift which might have completed with some additional hesitation. Other than that, perfect operation for 107 hours. I don't have an easy way to count the number of shifts, but there have been plenty.

I suspect the non-changing training conditions and the cool ambient air may have some effect in the RD's flawless performance. It will be interesting to get this unit on the road when the season starts.

Re: Sram eTap rear derailleur sporadically stops shifting - then performs all queued shifts at once?

Posted: Fri Feb 14, 2020 7:15 pm
by jever98
FWIW - I got mine replaced by SRAM without questions. Had the same hesitation issues.

Re: Sram eTap rear derailleur sporadically stops shifting - then performs all queued shifts at once?

Posted: Fri Feb 14, 2020 7:15 pm
by Weenie

Re: Sram eTap rear derailleur sporadically stops shifting - then performs all queued shifts at once?

Posted: Fri Apr 10, 2020 8:02 am
by b5000
Unfortunately, I experienced the same issues with a new 11 speed eTap wifli RD. My RD was exhibiting the same issues that are described in this thread - exactly like this video: https://www.youtube.com/watch?v=Qsz6Rz8_-Uw. The entire new eTap group was installed on a new R5 disc frameset and I had put about 680 miles on it - having only assembled the bike in late January of this year. RD was never damaged by any crashes or strikes on the RD cage or body & the hanger is straight, bike & groupset are both essentially new (gearing setup is 50/34 and 11/28). When it initially stopped shifting mid ride, I thought it was a dead battery - so I swapped the FD & RD batteries and that fixed it for about 5 mins then it stopped again. When I got back home and put it on the work stand and tested it with the chain on and without: EXACT issues as described by this thread and the video to a tee.

I contacted the shop where I bought the groupset and described the issues and they promptly sent me a RMA number for a warranty exchange and arranged to send me a replacement. All of this was handled very promptly and professionally by the vendor and I had a replacement within 9 days (received it today and promptly installed it on the bike).

I strongly suspect that there is an issue with the internal servo mechanics - probably a small internal part failed inside the mechanism. I won't speculate but this is common in other complex mechanical parts like fan impellers etc. I also suspect that SRAM knows about this and that this failure is very common for the 11 speed eTap RDs. I suspect that they have addressed this in the new AXS groupset - but alas on top of it being more expensive; I don't want or need it.

Fingers crossed that this replacement RD has no issues going forward as I really enjoy eTap so far & don't want to change to mechanical or another groupset.

Anyone else run into this issue with 11 speed eTap RD?