Ultegra Di2 charging probs

Discuss light weight issues concerning road bikes & parts.
Post Reply
toride
Posts: 124
Joined: Fri Sep 02, 2011 6:19 pm
Location: uk,lincs

by toride

I’m after some help with my di2, it won’t seem to charge.
I plug everything correctly (leaving all other wires connected?) and turn the plug on...the light on the charging box illuminates that is changing and both green and red lights very steadily flash but then it seems to stop charging and the ! Light becomes lit.

Do all wires stay in place ?

User avatar
TonyM
Posts: 2156
Joined: Thu Jan 22, 2015 4:11 pm

by TonyM

Which USB plug do you use?

There have been many reports on problems with the standard iPhone USB plug for example. I think Shimano recommends 1A. Some report that charging with the USB from the PC works best.

Do you see all the Di2 parts in the e-tube app?

Have you run the error diagnostics in the e-tube app?

User avatar
IrrelevantD
Posts: 270
Joined: Sun Nov 29, 2015 5:47 pm
Location: Near DFW Airport

by IrrelevantD

My guess is you're charging it from a <1W charger as TonyM mentioned. I'm also assuming you have an internal battery; to my knowedge, you can't charge an external battery through the A Junction box as with the internal.

Everything else stays connected, should only need to plug the charger into the A-junction.
* There is a 70% chance that what you have just read has a peppering of cynicism or sarcasm and generally should not be taken seriously.
I'll leave it up to you to figure out the other 30%. If you are in any way offended, that's on you.

toride
Posts: 124
Joined: Fri Sep 02, 2011 6:19 pm
Location: uk,lincs

by toride

Thanks for the response guys, I’ve now diagnosed a fault with the battery

Cheee

User avatar
TonyM
Posts: 2156
Joined: Thu Jan 22, 2015 4:11 pm

by TonyM

toride wrote:Thanks for the response guys, I’ve now diagnosed a fault with the battery

Cheee
How did you find it out?

toride
Posts: 124
Joined: Fri Sep 02, 2011 6:19 pm
Location: uk,lincs

by toride

I knew it was more than likely the battery or the charger so I tried another battery and the problem was solved, I was hopefull it might of been me doing something wrong, it wasn’t and I’ve treated it to a new battery.
Thanks for your interest

User avatar
TonyM
Posts: 2156
Joined: Thu Jan 22, 2015 4:11 pm

by TonyM

How old was the faulty battery?
Which battery was it? BT-DN100 or 110?

Post Reply
  • Similar Topics
    Replies
    Views
    Last post