Page 2 of 2

Re: Look Keo Blade Carbon Pedals 2018 - problems :?:

Posted: Tue May 29, 2018 6:47 pm
by fignonsbarber
richard@lbrc.org wrote:
Tue May 08, 2018 7:07 pm


I have a five week old pair of the new Look Keo Carbon 2018 pedals (CroMo). They will no longer hold my cleats (Look Keo Black) properly, my cleats actually 'rattle' inside the pedals when they are clipped in. And, yes - I've tried another brand new pair of cleats.


The shop will happly refund them, so atleast I didn't lose any money. I emailed Look Cycles - but no reply as yet.

R.
If the pedals suddenly feel like they have lost tension and it becomes "soft" feeling and no "snap" when you unclick, it means the carbon pedal body has cracked. I've broken 5 of these (I weigh 165 pounds). Carefully look at the bottom of the pedal body while flexing the release.

Re: Look Keo Blade Carbon Pedals 2018 - problems :?:

Posted: Tue May 29, 2018 6:47 pm
by Weenie

Re: Look Keo Blade Carbon Pedals 2018 - problems :?:

Posted: Tue May 29, 2018 7:44 pm
by Rick
MyM3Coupe wrote:
Tue May 08, 2018 10:40 pm
Tons of people have problems with the Look cleat/pedal interface. Ditch them and get some Shimano Dura-Ace pedals. No more problems.
That's my experience.
I now have 105, Ultegra, and Dura Ace and none of them has given the slightest squeak or problem for the past 5 or 6 years.
I bought a pair of Look Keo Blade II when they first came out, and I really wanted to like them because they were SOOO light and sexy looking.
I ended up selling them on ebay about a month later.

Re: Look Keo Blade Carbon Pedals 2018 - problems :?:

Posted: Wed May 30, 2018 11:36 am
by Juanmoretime
Another former Keo Blade user. My issues were creaking cleats and the pedal almost always had to be flipped over with my foot to clip in. I road Time Xpresso 12’s until they finally went bad. Now I’m on the Dura Ace 9100 pedals and creak free and the pedal flips on its own and is ready to engage when I am. They are not the lightest but just work.

Re: Look Keo Blade Carbon Pedals 2018 - problems :?:

Posted: Wed Dec 19, 2018 5:01 am
by ubers
Davidqld wrote:
Tue May 29, 2018 10:32 am
I love my keo blade Ti 2018 BUT there is a squeak from the bearings. I can’t work out how to pull the axel out and regrease it. Looks like a special tool might be needed as the design has changed quite a bit from the previous model and that’s the only one I can find instructions on how to remove.
I have the 2018 Blade's and want to open them up for a re-grease but can't figure out how to do this also. The old Blade 2's were pretty simple to open - just used a micro flat head screw driver to prise open the end cap. The new Blade's have a different end cap design (with tool indents? - see pic below) which indicates they might be threaded - can't find any guidance online as to how to open or if a special tool is needed :noidea: .

Image

Re: Look Keo Blade Carbon Pedals 2018 - problems :?:

Posted: Thu Jan 31, 2019 9:40 pm
by parajba
I need to buy a pair of Look pedals for my new Venge (Di2, CLX50, Quarq).
Which model do you recommend? The Keo Blade Carbon Cr seems to be a good compromise of £ and grams. They need grey cleats without grip.
Look forward to your thoughts.

I don’t want to change system as I am happy with the Look system.