Di2 9150 stops responding during software update. Please help.

Discuss light weight issues concerning road bikes & parts.
Aleksandr
Posts: 4
Joined: Sat Dec 09, 2017 8:28 pm
Location: Lithuania

by Aleksandr

Good Day Guys. Need advice regarding my Shimano Di2 9150 group set.
Yesterday receive Shimano Di2 Wireless Unit EW-WU111 D-Fly and install it on my new Canyon Aeroad CF SLX. On my iPad open E-tube Project and try to update the software as per Shimano recommendation. My new installed Wireless Unit EW-WU111 was detected and after that I was asking to update the software and I confirm it. When update came to 11% the E-tube stops and say it was not successful. I try to “forget the Bluetooth device” and start update again but noticed on my SM-EW90 3-port junction A installed under my handlebar NO any lights when you press the button on it. When I checked all the cables connections from the battery to the SM-EW90 3-port junction A – all ok. When I measured the BT-DN110 battery voltage and reading was 7,82 Volts and this voltage is correct. It is fully charged. I have checked my BB junction box as well. I can read 7,82 Volts on all in/out connection points on my both junction boxes and the same voltage on my rear and fwd derailleurs. I think this case is not battery or bad connection issue. Correct voltage present on all points.But as I mentioned before I have NO any lights on SM-EW90 3-port junction A. SM-EW90 3-port junction A is interface between all the components and It looks like not responding/died. So, on this stage I stuck and asking some advice. Maybe someone had the same or similar problem.
Additional I disconnect my battery for few minutes to RESET the system but still the same - Di2 not responding at all...
Probably next step is to connect my Di2 to PC and run diagnostic. In that case can I detect any problems? I cannot do this now as I have Mac and will do it with PC aon Monday.
Or maybe my SM-EW90 3-port junction A is died? How can I check this?
The place when I live we have NO any SHIMANO centers and technicians in the bicycle shops not familiar yet with Di2.

Thanks in advance.
Current Rides:

2018 CANYON Aeroad CF SLX DI2 9150

TurboKoo
Posts: 435
Joined: Wed Oct 29, 2008 7:55 pm

by TurboKoo

You seemed to have lost connection during update. Plug it to PC with PCE-1 (not sure if your charger also works) and after little while it’s fixed.
Scott Foil
Shimano 9150
Shimano FCR-9100-P
Shimano C60 tubulars

spartan
Posts: 1108
Joined: Fri Sep 03, 2004 2:52 am

by spartan

same issue happend to me when i was updating the wireless unit. do the following. unplug the battery. wait a minute. replug. the bios will reset to factory.
Current Rides:

2017 Giant TCR Advanced SL 0 DI2 9150


Aleksandr
Posts: 4
Joined: Sat Dec 09, 2017 8:28 pm
Location: Lithuania

by Aleksandr

spartan wrote:same issue happend to me when i was updating the wireless unit. do the following. unplug the battery. wait a minute. replug. the bios will reset to factory.



Thanks Spartan.
Did that as well. No result.

Will try to connect to PC.

Thank you.
Current Rides:

2018 CANYON Aeroad CF SLX DI2 9150

Aleksandr
Posts: 4
Joined: Sat Dec 09, 2017 8:28 pm
Location: Lithuania

by Aleksandr

TurboKoo wrote:You seemed to have lost connection during update. Plug it to PC with PCE-1 (not sure if your charger also works) and after little while it’s fixed.



In my case I will try make connection to PC with SM-BCR-2 and launch the E-TUBE.

Thank you.
Current Rides:

2018 CANYON Aeroad CF SLX DI2 9150

Aleksandr
Posts: 4
Joined: Sat Dec 09, 2017 8:28 pm
Location: Lithuania

by Aleksandr

Sorted!

All steps:
1. Downloaded E-TUBE to PC
2. Connected Di2 on SM-EW90 with SM-BCR-2
3. Open E-tube and got both flushing light on SM-EW90
4. Updated the software-just follow the steps.
5. Open E-TUBE on iPAD and connected with Di2 Wireless Unit EW-WU111 D-Fly ( installed on bike)
6. Updated all Di2 components.
7. All done ! Di2 9150 system working perfect.

Thanks for all replies.
Current Rides:

2018 CANYON Aeroad CF SLX DI2 9150

Delorre
Posts: 938
Joined: Sat May 24, 2014 12:09 pm

by Delorre

I'm glad you sorted it out! But given all the horor stories I already heard and read, I would only use the BT + app to make small changes to the bike while on the road, such as shift speed, shift points, buttons etc. As you have to plug the bike into the pc anyway once in a while for charging, check for updates etc when doing this, and you should no have any problmes with freezes etc as you encountered :wink:

User avatar
TonyM
Posts: 2166
Joined: Thu Jan 22, 2015 4:11 pm

by TonyM

So far I have always used the E-Tube App on my iPad/ iPhone without any problems, also including updates (9150 with EW-RS910 and EW-WU111).

In which cases would I need to use the PC software?

Delorre
Posts: 938
Joined: Sat May 24, 2014 12:09 pm

by Delorre

TonyM wrote:So far I have always used the E-Tube App on my iPad/ iPhone without any problems, also including updates (9150 with EW-RS910 and EW-WU111).

In which cases would I need to use the PC software?


Luck is on your side then, I have some riding budies that had the exact same type of issues as the OP here using only the app for everything. A couple of others I'm aware off that use only the PC software, never had any problem, me included :lol:

User avatar
TonyM
Posts: 2166
Joined: Thu Jan 22, 2015 4:11 pm

by TonyM

Ok I am going to install the E-Tube PC software on my Mac just in case...

User avatar
TonyM
Posts: 2166
Joined: Thu Jan 22, 2015 4:11 pm

by TonyM

No Mac OS version...
http://e-tubeproject.shimano.com

Will have to continue to use the iPad/ iPhone app.

eaglejackson
Posts: 257
Joined: Wed Aug 27, 2014 5:26 am
Location: PNW

by eaglejackson

Delorre wrote:
TonyM wrote:So far I have always used the E-Tube App on my iPad/ iPhone without any problems, also including updates (9150 with EW-RS910 and EW-WU111).

In which cases would I need to use the PC software?
Luck is on your side then, I have some riding budies that had the exact same type of issues as the OP here using only the app for everything. A couple of others I'm aware off that use only the PC software, never had any problem, me included :lol:
Agree with Delorre, luck has been on your side.

I used E-tube on my iPad to update the Di2 firmware and it bricked. I didn't at the time have a PC (only Mac) so couldn't connect to my PC. I had to take it to the dealer. They had to replace the battery which went FUBAR, reprogram and update via PC. What a mess e-Tube caused. Since then I haven't tried updates myself but rather had them done at the dealer.

User avatar
TonyM
Posts: 2166
Joined: Thu Jan 22, 2015 4:11 pm

by TonyM

eaglejackson wrote:
Delorre wrote:
TonyM wrote:So far I have always used the E-Tube App on my iPad/ iPhone without any problems, also including updates (9150 with EW-RS910 and EW-WU111).

In which cases would I need to use the PC software?
Luck is on your side then, I have some riding budies that had the exact same type of issues as the OP here using only the app for everything. A couple of others I'm aware off that use only the PC software, never had any problem, me included :lol:
Agree with Delorre, luck has been on your side.

I used E-tube on my iPad to update the Di2 firmware and it bricked. I didn't at the time have a PC (only Mac) so couldn't connect to my PC. I had to take it to the dealer. They had to replace the battery which went FUBAR, reprogram and update via PC. What a mess e-Tube caused. Since then I haven't tried updates myself but rather had them done at the dealer.
How old are your Di2 parts?
And which battery do you have?

eaglejackson
Posts: 257
Joined: Wed Aug 27, 2014 5:26 am
Location: PNW

by eaglejackson

TonyM wrote:
eaglejackson wrote:
Delorre wrote:
TonyM wrote:So far I have always used the E-Tube App on my iPad/ iPhone without any problems, also including updates (9150 with EW-RS910 and EW-WU111).

In which cases would I need to use the PC software?
Luck is on your side then, I have some riding budies that had the exact same type of issues as the OP here using only the app for everything. A couple of others I'm aware off that use only the PC software, never had any problem, me included :lol:
Agree with Delorre, luck has been on your side.

I used E-tube on my iPad to update the Di2 firmware and it bricked. I didn't at the time have a PC (only Mac) so couldn't connect to my PC. I had to take it to the dealer. They had to replace the battery which went FUBAR, reprogram and update via PC. What a mess e-Tube caused. Since then I haven't tried updates myself but rather had them done at the dealer.
How old are your Di2 parts?
And which battery do you have?
The parts are 3 year old Dura Ace 9070 Di2 with the BT-DN110 battery.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post