Page 1 of 1

Creaky Cables

Posted: Mon Jan 28, 2013 5:41 pm
by Wcl4
I recently installed some Aican cable housing with Powercordz. As I rotate the handlebars, some of the sections in the cable housing creak as the handlebars move left or right. None of the cables are touching each other, so it's not from cable slap. I can tell it's the section, because as I ride and hear the noise, if I hold onto the cables, the creaking stops. Anyone else have this issue with metal sectioned cable housing?

Thanks.

Re: Creaky Cables

Posted: Mon Jan 28, 2013 7:17 pm
by madmole
Little bit of chain lube will shut them up

Re: Creaky Cables

Posted: Mon Jan 28, 2013 7:17 pm
by Weenie

Re: Creaky Cables

Posted: Mon Jan 28, 2013 7:31 pm
by prendrefeu
You'll never hear them while riding, you know.

Re: Creaky Cables

Posted: Mon Jan 28, 2013 7:32 pm
by Wcl4
I'll give that try - thanks

Re: Creaky Cables

Posted: Mon Jan 28, 2013 7:48 pm
by Wcl4
Actually they do creak from the road vibration. I thought it was something more serious at first.

Re: Creaky Cables

Posted: Mon Jan 28, 2013 7:55 pm
by prendrefeu
Hmmm... that's some pretty heavy creaking then.
My cables slightly creak, but it's only audible when the bike is being manoeuvered around the house or when on the stand.

As stated above, lubing the cables & housing will help.

Re: Creaky Cables

Posted: Mon Jan 28, 2013 8:03 pm
by Wcl4
Worked like a charm. Thanks guys. Riding around with the creaking was driving me crazy.

Re: Creaky Cables

Posted: Mon Jan 28, 2013 8:26 pm
by Dennis
You can also use silicone spray, this helpes also but don't atrackt dirt.

Re: Creaky Cables

Posted: Wed Jan 30, 2013 11:23 am
by weeracerweenie
My I-Links do all the time, drives me NUTS, ive tried chain lube and wax and bloody everything. Theyve done a few kms though, so im might hook myself up with a new set... Best of luck, i like a quiet bike!

Re: Creaky Cables

Posted: Mon Jul 07, 2014 12:05 am
by drainyoo
Sorry for bringing up an old thread, but I didn't want to start a new one.

I'm having the same issues with my Aican Bunguras cables. Out of nowhere they started creaking like crazy today. I can hear it while riding.

Do you apply the chain lube inbetween each segment or on the entire housing?

Re: Creaky Cables

Posted: Fri Jul 11, 2014 10:02 pm
by colster
I had the same issue when I first installed Nokon cables and I know how annoying it can be.
I apply a smear of Shimano Special Grease to each and every bead with a fine brush, enough so that when you press them together a little grease is squeezed out. I do this once every 6 months when I refresh the inner cables and liner.
Works a dream, although it is quite time consuming.

Re: Creaky Cables

Posted: Fri Jul 11, 2014 10:49 pm
by ITTY
I get this issue after rainy rides on ilinks. Apply lube liberally, wipe clean, done.

Re: Creaky Cables

Posted: Fri Jul 11, 2014 11:25 pm
by shoemakerpom2010
Did exactly the same thing with my nokon and they work great.

Re: Creaky Cables

Posted: Sun Jul 13, 2014 7:27 pm
by wojchiech
Teflon-based lubes seems to work the best - no residue, high viscosity, cleans and polishes outers slightly, provides slight water resistance (I use Boe-shield). My ilinks were creaking for a while. What I thought was a creaky crank/BB/drivetrain turned out to be my cable housing. After spraying with boe-shield my housing is dead silent. Each application seems to last a while too. I think the last time I did this was last season. :thumbup: :beerchug:

Re: Creaky Cables

Posted: Sun Jul 13, 2014 7:27 pm
by Weenie