Page 1 of 1

Flite Gel Flow noise

Posted: Wed Dec 26, 2012 5:26 pm
by MaxDaddy
I've been using this saddle for only a brief amount of time. This past weekend I had a squeaking noise while riding that I couldn't figure out. I've torn the bike apart looking for it. Thought it was the seat post but now I think it's actually the saddle.

Looks like the shell might be contacting the rails up by the nose. Happens mainly when I'm spinning more than hammering. So I'm guess a little bounce contributes to it. I know, hammer more and spin less.

Anyway, I did some searching on the interweb and saw a few items about it but no definitive solution.

Has anybody had an experience like this, and if so were you able to correct it?

Re: Flite Gel Flow noise

Posted: Wed Dec 26, 2012 5:34 pm
by sungod
haven't got the saddle, but i'd try some spraying some silicone lube in there and see if it cures things

edit - before that, i'd check the clamp, clean the rails etc.

Re: Flite Gel Flow noise

Posted: Wed Dec 26, 2012 8:37 pm
by yeagermeister
If it is definitely the saddle rail junction, then just apply some white lightning crystal grease (or whatever you use for headsets and pedals axles) to the area and it should be fine, It's worked for me before with Fizik saddles.

Re: Flite Gel Flow noise

Posted: Mon Dec 31, 2012 4:31 pm
by Zigmeister
Lube the rail mount point with carbon paste. Also, I had this saddle, the nose does slip/move around at the mount points just a bit with force, assume by design. Put some lube up in the nose contact parts and see if that fixes it.

Besides those two points, not sure where else it could come from.