Broken Powertap SL+, after some help / advice

Discuss light weight issues concerning road bikes & parts.
Post Reply
Posts: 3
Joined: Fri Oct 05, 2012 12:06 pm

by DTV

Hi all, I was looking for a bit of technical help with a broken powertap.

It's an SL+ built into a Sub9 disc.

It had been working fine, and was on the second set of batteries. All of a sudden it stopped transmitting power data during a ride. There was no accident / bump / rain that I'm aware of.

I have changed the batteries with type 357 (the recommended silver oxide ones), and also tried EPX 76 (the recommended alternative), and the unit still doesn't work.

I live in Hong Kong and have sent it back to the local distributor but they say they cannot service it and sending it back to the US will cost me US$1500.. if they can do it al all. They haven't been too interested. But they have changed the batteries again and confirmed this is not the problem.

The inside of the unit appears clean and dry and the battery connection appears to be good.
When I power the unit up my Garmin Edge 500 can see the powertap. It will pair with the unit and there is a powertap ID.
When I select the Calibrate menu it does give a torque reading (generally around 0.15-0.3 when I vigorously hand pedal with the bike in a workstand). And it does respond to changes in force with different torque settings.
However the power reading on the main display is 0w (including if I take the bike out for a ride).
If I select Calibrate Unit on the Calibrate menu it says Calibrating... and then just stays there. However it has always done this.

I've also tried a second Garmin edge 500 and a Garmin 310xt and it's the same on all units.

I know it is difficult to diagnose the unit remotely but I essentially have no way of getting it back to the US and the local distributor has no technical ability to service the unit. It seems like the strain gauges are working as it can measure torque, and it is transmitting that data to the Garmin head unit, but it doesn't send a power reading. I'd really appreciate any help.
Thanks again,

by Weenie

User avatar
Posts: 2035
Joined: Sat Aug 29, 2009 4:30 pm

by Rick

If I select Calibrate Unit on the Calibrate menu it says Calibrating... and then just stays there. However it has always done this.

Sometimes it takes a loooooooong time to calibrate. Have you ever just left the bike motionless with crankarms horizontal until a calibration number comes back (up to a full 5 minutes or so) ?

I don't know why the calibration usually takes a few seconds, but occasionally takes a very long time. The first time I noticed the exceptionally long cal time was after updating my Edge 500 software to the latest rev. I thought something must be wrong, but eventually the same number I am used to seeing came back as the calibration constant ("512")

Posts: 334
Joined: Mon Apr 05, 2010 4:14 pm

by petromyzon

This might not be the most helpful comment ever, but I seem to remember that the Zipp discs with PT wheels built in were a special case that could only be serviced in the US by Zipp.

Powertaps are a great product but the design is modular and if the electronics ever misbehave the attitude seems to be replace, not repair. All good if the device is in warranty, expensive if not!

User avatar
Posts: 5771
Joined: Tue Sep 26, 2006 12:37 am
Location: Phoenix Arizona

by CharlesM

Email me your contact information.

Posts: 3
Joined: Fri Oct 05, 2012 12:06 pm

by DTV

Thanks guys, appreciate all the help.

I'll try leaving the calibration function going and just see what happens, maybe it's just not calibrated. It seems odd that the garmin can connect and sees a powertap ID and torque readings, but no power. I would have thought torque was essentially the same as power but maybe I'm missing something.

And yep, you're right, needs to be sent back to Zipp in the US, which the local distributor has put into the too hard basket. Bit frustrating.

The Saris guys have tried their best to help but as mentioned above, I think their service policy is 'if broken just replace it'.

Thanks again for all the help,

Posts: 13
Joined: Wed Dec 14, 2011 8:45 pm
Location: Switzerland

by axl13

I'm having exactly the same symptoms lately on my Powertap Pro+. The initial batteries lasted a bit over a season, after I put the new ones it did work fine but they run flat within a few month (i'd say under 20h of actual riding). Now I'm on the third set of batteries, and the power reading stay on "0w", briefly changing to something within "1-100w" on acceleration and hills. :roll:

Does it make sense to try CycleOps head unit for recalibration (i tried Edge500, 910XT)?

by Weenie

Post Reply
  • Similar Topics
    Last post