Garmin 510 Erratic Speed recording....

Questions about bike hire abroad and everything light bike related. No off-topic chat please

Moderator: Moderator Team

Post Reply
User avatar
TrekUk
Shop Owner
Posts: 353
Joined: Mon Jan 14, 2013 5:45 pm
Location: UK

by TrekUk

I have just purchased 510 and done two rides on this and discovered a major flaw with the recording of speed. The speed seems to be inconsistent and dropping at regular intervals almost consistently over the whole ride. I have updated to the latest firmware already 2.70, and cannot figure for the life of me after searching google why this would be happening, my edge 200 was faultless and even the iphone app was more consistent with speed recording

I have also set GPS to GLONAS.

Take a look at these....

A friends edge 510 speed recording, normal for everyone....

Image

Now my speed recording thats affecting alot of data recording, Garmin upload said 18.3 miles ridden strava uploaded it as 20.4miles, garmin average speed 14.9mph and strava 16.1mph average, calories was also incorrect!!

Image

and zoomed in on a segment....

Image


can anyone explain whats going on here and what could I do to sort this? I cant find any other posts with the same problem.
Madone Five Series 2013
Shimano Dura-Ace 9000
Mavic Cosmic SLE 2013

User avatar
jekyll man
Posts: 1360
Joined: Wed Apr 25, 2007 10:23 am
Location: Pack filler

by jekyll man

Does it do this on anything else on garmin connect or any other prog as well as strava?
Livetracking and your phone data connection?

Did you charge it properly first?
Official cafe stop tester

afalts
Posts: 157
Joined: Thu Mar 08, 2012 3:20 pm

by afalts

http://www.scarletfire.co.uk/2013/06/ho ... on-strava/

Go to the 20% boost example :lol:

All digital cheating aside though, I vaguely remember hearing of someone using an Ant+ speed sensor and it causing troubles like that. Garmin said they thought there was a bug and it was having trouble deciding between GPS and the sensor's speed. Are you using a speed sensor or just relying on GPS speed?

What are you using to upload it to Strava? Straight from the Garmin on Strava's site? I have seen Strava make a mess of files uploaded through various different programs.

Maybe try calling Garmin? They've always been good on the phone with my customers in North America.

User avatar
TrekUk
Shop Owner
Posts: 353
Joined: Mon Jan 14, 2013 5:45 pm
Location: UK

by TrekUk

Appears it must be a but when auto stop is set to custom speed......dont try it...
Madone Five Series 2013
Shimano Dura-Ace 9000
Mavic Cosmic SLE 2013

wpccrunner
in the industry
Posts: 365
Joined: Fri Dec 07, 2012 8:34 pm
Location: North Carolina

by wpccrunner

I hope you're climbing a hill with a ride that short and slow :smartass:

Pivens
Posts: 171
Joined: Wed Feb 08, 2006 10:22 am
Location: Moncalieri (Turin), Italia.

by Pivens

I've experienced the same issue. I don't think it depends on the auto stop, because mine is not set at custom speed.
I used:
GPS+Glonass
No speed/Cadence sensor
1s recording
SRM
HR
Strava upload straight from the 510's .fit file
Image

User avatar
ave
Posts: 1719
Joined: Sun Dec 28, 2008 10:15 pm
Location: Hungary

by ave

I've no idea of the how the twin positioning system's work on the 510.
But in general, if data is gathered from two sources, then the joining of them can result in glitches like this. Of course it should not be eliminated by the firmware.

ridonkulus
Posts: 22
Joined: Fri Nov 22, 2013 5:12 pm

by ridonkulus

That happened to me a few moths back. Ended being a bad speed/cadence sensor. First try to reset the sensor and make sure the magnet is place close enough. On rides with the speed jumping around I would just disconnect it and use GPS. Try emailing Garmin for a new cadence sensor, it will take a long time with their excuses and make you do lots of stuff before they send you a new one, but it will happen.

dmp
Posts: 332
Joined: Fri May 08, 2009 8:31 pm
Location: Denver

by dmp

Pivens, I hope that is not your ECG...

Post Reply
  • Similar Topics
    Replies
    Views
    Last post