Corima Aero+ Freehub Help

Everything about building wheels, glueing tubs, etc.
Post Reply
heppy997
Posts: 2
Joined: Fri Mar 17, 2017 9:52 pm

by heppy997

Evening guys,

I've got a rear Corima Aero+ carbon tubular wheel which is giving me some grief. I stripped the hub some time ago to replace the bearings, but for whatever reason it got left for some time and when I've got back round to sorting it I can't remember how it came apart (!).

Basically, when the freehub is installed, and I try to screw the cones in on either end of the axel, as soon as there is a hint of tension, the freehub tightens up. Its like they're pressing right on the rubber bearing seal and tightening it all up. Could someone familiar with these wheels shed some light on this? I'm not sure if I'm missing a washer or something. I've checked the exploded view and it all looks there.....

Some pics: https://drive.google.com/open?id=0ByEBC ... F9xLVRieUk

Thanks

tweets
Posts: 14
Joined: Thu Nov 13, 2008 9:50 pm

by tweets

I'm guessing you are missing the slide on sleeve spacer between the freehub and the outside bearing in the hub?

by Weenie


heppy997
Posts: 2
Joined: Fri Mar 17, 2017 9:52 pm

by heppy997

Thanks for that. It was missing a small sleeve between the freehub and hub like you said. Also, I had a few end cones for the non drive side which are very slightly different. The one I had was pressing against the actual bearing seal and hence stiffening it up. I swapped it out and they tightened up fine. Headache over!

Post Reply
  • Similar Topics
    Replies
    Views
    Last post