XX1 (10-42) Cassette with XTR Deraillieur

Discuss light weight issues concerning mountain bikes & parts.

Moderator: Moderator Team

User avatar
maddog 2
Posts: 349
Joined: Wed Feb 25, 2009 7:58 pm
Location: Lancaster, UK

by maddog 2

sounds like the problem is the XD driver, to me.

It's (somehow) sitting too far inboard. Is it the correct XD driver for that hub?

[I run a number of Sram 10-42 cassettes with XT and XTR mechs, no problem]

The issue isn't the mech, the issue is the cassette is too far inboard, which is therefore a XD driver issue as the Sram cassette only fixes on in one way i.e. no spacers or anything.

egebhardt
Posts: 31
Joined: Wed Mar 19, 2008 8:38 pm

by egebhardt

I'm sold. I'll be trying this soon. I've got all the parts but haven't pulled the trigger yet.
Eric in San Carlos, CA

by Weenie


User avatar
DOUG
Posts: 203
Joined: Thu Mar 31, 2016 9:54 pm

by DOUG

Just an update on this one, I ended up going with an XTR cassette with the OneUp 45T conversion kit and using a 34T chainring (which I had anyway). Worked flawlessly out of the box, only needed 2 clicks on the barrel adjuster to get it dialed.

I still have the cassette sitting there waiting until I have enough time to muck around with it but for now I'm just enjoying riding the bike. Ill update this thread with a solution once i get to it just in case someone finds this and has the same issue!

niklasp
Posts: 66
Joined: Thu Jul 14, 2016 5:36 pm

by niklasp

Got similar problems.
Been running xt shifter and rear derailleur with a sram 10-42 gx cassette without problem, but changed to a xx1 cassette 10-42 and at first the index was off. Didn't work to adjust low / high (high was fine) and the b tension screw was perfekt.
It's almost like indexing is off. If I adjust the barrel adjuster to make it go away the chain won't come down at the 10 cog.
I installed the gx cassette again and it works great again. Come on its a saving of 130g :roll: so help me please.

Almost new chain that doesn't indicate wear. Cassette bought second hand but very little used.

User avatar
DOUG
Posts: 203
Joined: Thu Mar 31, 2016 9:54 pm

by DOUG

Just to close this one off, I bought the XD driver for my new wheelset (Project 321 hub) and put the XX1 casette on and voila. No problems at all. So in conclusion it was def some problem with the hub spacing on the Mavic hub that was causing the indexing problems. Happy to finally have this one sorted out!

Post Reply
  • Similar Topics
    Replies
    Views
    Last post