Di2 XTR firmware update issues??

Discuss light weight issues concerning mountain bikes & parts.

Moderator: Moderator Team

Post Reply
Posts: 5
Joined: Tue May 17, 2011 2:31 pm

by yancart

Hi, Im trying to setup a 1x11 XTR Di2 and having a few issues...

Just using the EW90A 3port junction, SM-BTR2 internal battery, the M9050 rear mech & a RH shifter, so running with no display and usingg the BCR2 charger for charging/updating.

Intially connected it up off the bike and all seemed to shift ok. Then fitted it to the bike and did the adj setup in 5th gear. Shifts were good but I couldnt get it shift into the highest gear (10t). Tried really loosening the end stop screws, which works for 42t but not 10t?

Then thought a firmware update might help, so connected the bike to the shimano e-tube project app v3.1.0. This worked fine, worked out what I had on the bike and said all parts needed a firmware update. So did the update and now the e-tube project app is happy and all seemed fine. I disconneted the bike from the laptop and now nothing. Now the shifter has no effect and the junction unit wont go into adj mode! I disconnected everything and reconnected it - same, nothing! I have a spare SM-BTR2 battery so connected it and all seemed fine again, apart from it still wouldnt shift into the 10t cog! Connected the bike back to the e-tube project app and again it said the battery firmware needed updating! Decided not to do this after what happened to the first battery!

Anyone got any ideas how to force a new firmware update using a SM-BTR2 charger? Or any other ideas?


by Weenie

Post Reply
  • Similar Topics
    Last post