Bont Vaypor+ and Look Keo issues

Discuss light weight issues concerning road bikes & parts.
Post Reply
Posts: 3
Joined: Thu May 25, 2017 10:30 am

by girona

Was wondering if anyone else is having issues with Keo cleats on Bonts? I have both Keo Max 2 pedals as well as Keo Blade Carbon. Never had problems with other shoes. I recently purchased some Bont Vaypor+ shoes and have found I was get really bad squeeking coming from the cleat rub against the pedal. There is a lot of play, and some vertical movement going on. Basically the pedal is not holding the cleat nice and tight like it should. I have tried all sorts for Keo cleats: grey, red, grip, no grip, as well as Exustar cleats, but all have them same issues. I am guessing the Bont sole is not matching perfectly with the cleat, and the cleat is getting deformed when I tighten them.

Anyone else with this problem? Any suggestions on a fix besides buying another brand pedal??

Thanks for any help you might have!

by Weenie

Posts: 1427
Joined: Fri Dec 24, 2010 9:37 pm
Location: it's raining, it must be uk

by sungod

fwiw i had a problem fitting speedplay zero to bont riot 2017 (vaypor s was fine)

the curve on the riot's didn't match any of the zero shims, but i had some aero shims and found a 'mix' with the zero shims would match the plate to the sole

if it's a similar issue you should be able to see any gap between cleat and sole (before tightening), if it isn't matching try using some thin hard plastic or metal from drink can to make a shim to match it

User avatar
Posts: 376
Joined: Wed Dec 29, 2010 2:16 am

by TwiggyTN

Yeah, you have to shim it with some type of material. I ride Xperesso's but had similar issues. The sole doesn't have the necessary curvature like Sidi for example which was plug and play. Ended up using some bartape material to shim the center of the cleat to get the right arc. It's not perfect but functions now as it should.

Sent from my SM-N920V using Tapatalk

Post Reply
  • Similar Topics
    Last post