HOT: Active* forum members generally gain 5% discount at starbike.com store!
Weight Weenies
* FAQ    * Search    * Trending Topics
* Login   * Register
HOME Listings Blog NEW Articles FAQ Contact About




Post new topic Reply to topic  [ 29 posts ] 
Go to page Previous  1, 2
Author Message
PostPosted: Fri Apr 04, 2014 3:50 am 
Offline

Joined: Wed Feb 19, 2014 6:13 am
Posts: 65
I concur the record chain is excellent, and the rings are explicitly compatible with them... Just thought it's worth a shot as far as trouble-shooting to see if that changes things.
Also may be worth making sure that the derailleur is low enough and that it's at a good angle front-to-back (not side to side) which would be a feature of the frame... e.g. close to the rings towards the front of bike, but large gap at the tail of derailleur - this is unlikely to be a factor, but sometimes is on Compact setups...

Just guessing at this point though. Good luck!!


Top
 Profile  
 
Posted: Fri Apr 04, 2014 3:50 am 


Top
  
 
 Post subject:
PostPosted: Fri Apr 04, 2014 3:53 am 
Offline

Joined: Tue Apr 17, 2012 11:20 am
Posts: 325
.


Last edited by Causidicus on Wed Jun 18, 2014 12:32 am, edited 1 time in total.

Top
 Profile  
 
PostPosted: Sat Apr 05, 2014 4:14 pm 
Offline
in the industry

Joined: Mon Apr 04, 2011 9:59 pm
Posts: 66
Location: Santa Cruz, CA
Hi folks...Adam from Praxis here.
This thread came up on my radar and I wanted to reach out.

We have a huge amount of customers with this exact setup and loving it, so I'm interested in what the possible issue is also.
Our rings on a Quarq (new and old Quarq) with Campy 11 has actually become a very common setup we've been helping people with.

One simple first fast step would be to please check the mounting. Believe it our not, we actually find that many have actually mounted our inner rings in the wrong timing position and also many times flipped the wrong way. Both of these will completely mess up the shifting.
This is one of our #1 calls/emails and is quickly fixed.
We're soon adding/updating the ring markings to make it less likely that someone accidentally mount them wrong.
Here is our mounting guide to follow - http://www.praxiscycles.com/wp-content/ ... unting.jpg

Other than checking that, like you guys mentioned in this thread...I'm very curious about the chain, the FD setup and the FD mount/braze on as we come across flexy mounts with frequency also.

Anyway...we're shifting geeks and just want to help out. So by all means email or call us and we'll for sure try and help shake down the potential issue.

Adam@Praxis

_________________
Praxis Works
Manufacturer
Santa Cruz, CA
www.praxis-works.com


Top
 Profile  
 
PostPosted: Tue Apr 08, 2014 4:29 am 
Offline

Joined: Sat Feb 23, 2008 6:33 pm
Posts: 254
the rings are indeed mounted correctly. i have sent pictures to Praxis customer service when they were first warranted to confirm this. i have had 3 different mechanics look at the FD and try as they might to get it to work without success.

crankset is Quarq Riken 170 53/39
chain is Campagnolo Record 11
1st bike was a Cannondale Evo with a Braze-On mount
2nd Bike is a Litespeed C1R with Braze-On mount.

this is my second set of rings, and although it works better than the first set, they are far from what i was expecting as far as shift quality. sometimes the chain will refuse to go from the 39 to the 53 unless i drop down a gear or 2 in the rear, shift back to the 39, and then shift again to the 53. i'm not impressed at all.


Top
 Profile  
 
PostPosted: Thu Jul 24, 2014 10:53 pm 
Offline

Joined: Mon Jun 02, 2014 1:10 pm
Posts: 15
I have bb30 Quarq Riken (with Omnical). The shifting with my 10spd Force is problematic,the chain is having a really hard time to shift from small to big gear (front).

Changed to Praxxis Works and it became much worst! Changed to SRAM Red (hidden bolt) and it perform magically perfect.


Top
 Profile  
 
PostPosted: Fri Jul 25, 2014 5:41 am 
Offline

Joined: Wed Jan 01, 2014 6:20 pm
Posts: 25
if the chain is having trouble to go from 39 to 53, why not just loosen the outer limiting screw on FD and increase abit cable tension. This ensures the FD goes the extra miles to bring the chain up to 53. Granted you won't be able to cross chain as much as before, but i remember campy have great FD trim feature.


Top
 Profile  
 
PostPosted: Fri Jul 25, 2014 11:25 am 
Offline

Joined: Fri Jan 27, 2006 1:38 pm
Posts: 580
Location: Greater Pittsburgh
Parxis (52/36)/KMC X11SL chain/Quarq SRAM Red/SR EPS on my wife's Parlee Z5 SLi. Shifts like a dream!

_________________
"Suddenly the thought struck me; my floor is someone elses ceiling" - Nils Ferlin


Top
 Profile  
 
PostPosted: Fri Jul 25, 2014 1:01 pm 
Offline

Joined: Sat Jun 06, 2009 7:28 am
Posts: 480
The solution to your problems does not lie in purchasing more parts. You need to have your existing parts adjusted by a person who knows what they're doing. I suggest that whomever has tuned your front derailleur doesn't know what they're doing.


Top
 Profile  
 
PostPosted: Fri Jul 25, 2014 1:10 pm 
Offline
User avatar

Joined: Wed Nov 09, 2011 12:19 pm
Posts: 34
Location: Switzerland
Just to add another success Story.. after continous chain drops (switched chains, added k-edge) I mounted Praxis Rings on my EVO. No drops since then (did the last two races with this setup), and smooth effortless shifting.

Setup: Supersix EVO, Quarq Elsa, Campagnolo Super Record, KMC X11 SL..

Image

Image

_________________
Supersix HiMod, Supersix EVO HiMod, Crux, CaadX, Lynskey R330 & Pro29, Yelli Screamy 29


Top
 Profile  
 
PostPosted: Fri Jul 25, 2014 1:25 pm 
Offline

Joined: Mon Jan 30, 2012 8:57 am
Posts: 90
Image

No issuses here.. :smartass:


Top
 Profile  
 
PostPosted: Thu Apr 02, 2015 5:13 am 
Offline

Joined: Sat Feb 23, 2008 6:33 pm
Posts: 254
to follow this up - a quick summary:

Canondale Evo new build with Record 11 group and Quarq Riken with Praxis 53/39 rings

The shift from the 39 to 53 is random- sometimes it works, other times I have to shift and re-shift 3-4 times to get it to catch

Check ring positioning and FD adjustment with 5 different mechanics- everything checks out

Praxis warranties rings, new rings mounted

Same issue, nothing changes despite numerous mechanics trying to adjust FD

I live with bad shifting for a year

The following year, I swapped my group over to a new Litespeed C1R. Same issue- 39 to 53 is intermittent

I swap FD from Record to Chorus hoping the metal Chorus FD will be stiffer and improve shifting. Does not work any better

Numerous mechanics try and fail to tweak FD to make it work

Finally, left shifter goes south. I replaced the mechanicals and when remounted, I found that my FD shifting issues were cured.

As it turns out, the problem all along was that I received a faulty Record shifter from Campagnolo right out of the box.

Problem solved, but i have to live through 2 years of bad shifting and $$$ trying to fix it. I wish I could have diagnosed this and gotten the shifter warrantied.

thanks for all the advice here.


Last edited by r_mutt on Thu Apr 02, 2015 1:09 pm, edited 1 time in total.

Top
 Profile  
 
PostPosted: Thu Apr 02, 2015 9:31 am 
Offline
User avatar

Joined: Sun May 04, 2008 10:03 pm
Posts: 827
Location: Back in the saddle...
Well, I guess all there is to say is at least it's working now! Sorry it was such a pain.

_________________
"Deserve's got nothing to do with it." William Munny


Top
 Profile  
 
PostPosted: Thu Apr 02, 2015 9:54 am 
Offline
User avatar

Joined: Sun Sep 19, 2004 6:21 pm
Posts: 1818
Location: around Paris
Confirms Praxis wasn't at fault, great stuff.

This kind of topic could make unfair bad publicity for them.

Well, they're enough praised anywhere else to counter balance but..


Top
 Profile  
 
PostPosted: Thu Apr 02, 2015 1:10 pm 
Offline

Joined: Sat Feb 23, 2008 6:33 pm
Posts: 254
Yes, this is why I typed a follow up to this to close the case!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 29 posts ] 
Go to page Previous  1, 2


Who is online

Users browsing this forum: Bacchus, Exabot [Bot], glepore, nickf, shadowman, shinzomaeda, Yahoo [Bot] and 60 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

   Similar Topics   Author   Replies   Views   Last post 
There are no new unread posts for this topic. Need help: Which Praxis Works Conv BB for S-works Sl4 to UT

[ Go to page: 1, 2 ]

in Road

poppiholla

22

311

Mon Apr 27, 2015 5:15 pm

poppiholla View the latest post

There are no new unread posts for this topic. Praxis Works BB30 BB

in Road

mitchgixer6

6

978

Mon May 19, 2014 5:17 am

mitchgixer6 View the latest post

There are no new unread posts for this topic. How many miles do you have on the Praxis chainrings?

in Road

allenpg

10

758

Thu Feb 12, 2015 2:49 am

TwiggyTN View the latest post

There are no new unread posts for this topic. Praxis Rings Weight

in Road

Ozrider

8

872

Tue Sep 16, 2014 6:34 pm

RyanH View the latest post

There are no new unread posts for this topic. Praxis campag bb conversion shipping!

in Road

sugarkane

11

1049

Fri Jun 20, 2014 2:06 pm

Butcher View the latest post


It is currently Wed May 06, 2015 1:32 pm

All times are UTC + 1 hour




Advertising   –  FAQ   –  Contact   –  Convert   –  About

© Weight Weenies 2000-2013
hosted by starbike.com


How to get rid of these ads? Just register!


Powered by phpBB