Weight Weenies
* FAQ    * Search    * Trending Topics
* Login   * Register
HOME Listings Blog NEW Galleries NEW FAQ Contact About Impressum
It is currently Mon Oct 16, 2017 11:19 pm

All times are UTC+01:00





Post new topic  Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Fri Jun 14, 2013 10:38 pm 
Offline

Joined: Tue Jul 27, 2010 10:04 am
Posts: 682
A recent switch from Shimano to Campag necessitated changing the freehub on my Dati hubs. It was a five minute job and all seemed well. On the workstand the Campag freehub engages to pedal and coasts/freewheels nicely. However whenever I actually take the bike on the road the freehub engages fine to pedal but whenever I coast/freewheel the freehub begins to intermittently jam or snag causing the chain to slap off the chainstay. I've tried various different lubricants ranging from light oil, medium oil, TriFlow and light grease but the problem persists. I also removed the Campag freehub and re-fitted the orginal Shimano one again, which had been working perfectly, and now it's doing the same! So obviously there's nothing wrong with the Campag freehub and it's more a problem with the manner in which I'm fitting the freehub. When I initially removed the Shimano freehub I do recall noting that there was a definite lack of any lubricant but, that said, it was working fine. Is there a specific lubricant I should be using with these Dati hubs or am I missing something in the fitting process? Any comments would be appreciated. Ta.

_________________
Belgian Flag S-Works Tarmac viewtopic.php?f=10&t=144553

"Sometimes you don't need a plan. You just need big balls." Tom Boonen


Top
   
PostPosted: Sat Jun 15, 2013 4:08 pm 
Offline
User avatar

Joined: Wed Apr 25, 2007 10:23 am
Posts: 1260
Location: Pack filler
I can't comment on that particular hub, but usual suspects are:
Too much grease ( esp in DT hubs)
Seals binding. Has it got a big flange seal that's not sat properly?
Reassembled incorrectly? The few novatec and KT hubs that I've worked on have always been a pain, and I did find a way that got around this problem. Can't remember what it was though, sorry.
Is It possible to mount the free hub to the axle and lock it up, then fit to the hub?
Hope any of this helps...

_________________
Official cafe stop tester


Top
   
Posted: Sat Jun 15, 2013 4:08 pm 


Top
   
 
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 2 posts ] 

   Similar Topics   Author   Replies   Views   Last post 
There are no new unread posts for this topic. SRAM Etap FD is driving me up the wall...

in Road

jimaizumi

4

736

Fri Feb 17, 2017 3:23 am

jimaizumi View the latest post

There are no new unread posts for this topic. nvroadie's Red Derailleur- Need all your crazy tuning ideas!

in Road

nvroadie

1

416

Thu Mar 16, 2017 9:53 am

Marin View the latest post

There are no new unread posts for this topic. Tune freehub

in Road

steelme

7

692

Wed Apr 12, 2017 9:51 pm

steelme View the latest post

There are no new unread posts for this topic. a freehub question

in Road

paregreen23

3

514

Wed Oct 19, 2016 9:59 pm

paregreen23 View the latest post

There are no new unread posts for this topic. Campagnolo Freehub help

in Road

marco fan

8

697

Thu Apr 20, 2017 2:13 pm

Madone69 View the latest post


All times are UTC+01:00


Who is online

Users browsing this forum: DiegoMendes, genesis692, Google [Bot], Google Adsense [Bot], jwfinesse and 40 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited