Ticking noise on C60?

Discuss light weight issues concerning road bikes & parts.
wilwil
Posts: 130
Joined: Thu Sep 23, 2010 5:47 pm

by wilwil

I have a ticking noise every crank revolution when my right foot is at 1-2 o'clock. Could this be the Campy BB cups or do they make more of a creaking sound? It was worse when I started the ride but now its not going away. It wasn't there for a few months after the bike was built, its something that has developed. Any ideas?

by Weenie


wedgie
Posts: 26
Joined: Mon Feb 22, 2016 9:41 pm

by wedgie

More likely to be the ultra torque bearings moving in the cups. I've had the same problem. Removing the crankset and re-greasing the bearing-cup interface helps for a few hundred kms but the noise will come back.

User avatar
Mockenrue
Posts: 377
Joined: Mon Aug 20, 2012 10:32 am
Location: UK

by Mockenrue

I had this for a while. Doing the above plus applying a little grease to the hirth joint teeth and crank bolt threads stopped it.

Zakalwe
Posts: 335
Joined: Sun Jun 17, 2012 3:15 pm

by Zakalwe

Grease your cleats

wobbly
Posts: 213
Joined: Tue Sep 26, 2006 3:50 pm

by wobbly

Saddle rails or seat post ??

lone wheeler
Posts: 481
Joined: Mon May 22, 2006 11:34 am
Location: Dubai, UAE
Contact:

by lone wheeler

Had same thing on my C60, thought it was the BB. Changed wheels and it went away so put the original wheels back in (lightweights) after putting a little grease on the skewers and it went away.

Imaking20
Posts: 1466
Joined: Fri Nov 18, 2011 5:19 am

by Imaking20

Had this on my white C60. It was reproducible after two different bearing cups (installed with loctite) and in the stand with no wheels installed. I blame threadfit or the Campy crank. Running a THM crank on my blue bike with no issues (and same skewers).
Current:
T2

Retired:
Blue | Project C6.0 | Felt AR FRD | Colnago C59 NERO | 2014 S-Works Tarmac | S-Works Venge | Wilier Cento Uno SL | Tarmac SL2

User avatar
micky
Posts: 4632
Joined: Thu Sep 21, 2006 8:57 pm
Location: Vicenza
Contact:

by micky

As others are suggesting, start from simple things like swapping skewers, wheels, using some WD40 or similar on all bolts/nuts, and so on.

Alexandrumarian
Posts: 128
Joined: Mon Mar 28, 2016 6:34 pm
Location: Romania

by Alexandrumarian

Chainring bolts can make ticks/creaks too...

wilwil
Posts: 130
Joined: Thu Sep 23, 2010 5:47 pm

by wilwil

Ive checked skewers and mech hanger. The BB cups are greased. will check chain ring bolts...

jmagoulas
Posts: 111
Joined: Mon Dec 26, 2016 3:00 am
Location: Connecticut USA

by jmagoulas

Also had the same issue on my C60. Would grease the cups and would go away for a bit. Some anodizing rubbed off on the inside, driveside cups so I thought to swap out with some new cups. Has been dead silent for 500+ blissful miles.

mfin
Posts: 11
Joined: Sun Jul 26, 2009 10:17 am

by mfin

Crank flicking the cable of the FD?

vanillaflyweight
Posts: 17
Joined: Thu Aug 10, 2017 5:54 am

by vanillaflyweight

I've had a similar thing happen once before. Turned out one of the chain ring bolts had come loose and was hitting the frame (hence once per revolution) By the time i had found the issue the gel coat had worn away. Could have been much worse though.

shipley
Posts: 35
Joined: Thu Sep 23, 2010 11:01 am

by shipley

My look pedals caused mine......fixed by greasing the axels.

ipenguinking
Posts: 466
Joined: Sun Jan 09, 2005 5:14 pm
Location: Sunny So Cal

by ipenguinking

Fixed the ticking noise on my C60 yesterday by lubing chainring bolts before torquing to Shimano's spec. All chainring bolts are either lose or dry on my 2-month old Pioneer PM. That's bad QC for Pioneer.

by Weenie


Post Reply
  • Similar Topics
    Replies
    Views
    Last post