HOT: Active* forum members generally gain 5% discount at starbike.com store!
Weight Weenies
* FAQ    * Search    * Trending Topics
* Login   * Register
HOME Listings Articles FAQ Contact About




Post new topic Reply to topic  [ 16 posts ] 
Go to page 1, 2  Next
Author Message
PostPosted: Sun Feb 17, 2013 5:06 pm 
Offline
Shop Owner
User avatar

Joined: Tue Jan 10, 2006 3:53 am
Posts: 295
Recently I notice that left side clip in tension was rather low and I did not get the clip in sound and feel on my, about 2 years old, Look Keo Blade Ti pedals .
Up on close examination, I have found that the engagement moving carbon part to be Cracked . Because the part is crack , the pedal fail to provide necessary tension when clipped in and a slight moment will disengage.
Now i have never have crashed on my road bike and am generally easy on my equipments because I weight 55kg .

Anyone have experience with Look customer service before ? any contact or email is much appreciated .

Thank you

Image


Top
 Profile  
 
PostPosted: Sun Feb 17, 2013 7:50 pm 
Offline

Joined: Sun Dec 02, 2012 2:50 pm
Posts: 1
Location: California
Hi... I closed a fit and custom bike studio a number of months ago, but did a lot with Look. I sold at least a couple hundred sets of Blades, and I have been on a set that came out of the first shipment to the US. I'm 79kg. The only issue that has come up (just once) was one of the actual blades (the strip of carbon) came out. The original plan was for the blades to be user or shop replaceable, so that owners could choose or change the engangemen tension. That plan seems to have fallen by the wayside. Now you buy 12nm or 16nm pedals and you get what you got.

However... given that there must be room for flex, and to allow replacement or repair, there must inherently be a way for that to happen. I'm surprised it's only come up once. But no cracking.

Look customer service is great. I'm in the US and dealt with a their call center here--it may be different if you are elswhere They've taken care of any issue I've throw at them, even when it clearly WASNT an issue with the product (and I told them that was my assessment as well)--they replaced a product simply to satisfy a customer.

The blade is their flagship pedal, expensive, and the basis for their new "power" pedal... they don't want poblems, or people talking about problems! You shouldn't have any problem at all!


Top
 Profile  
 
Posted: Sun Feb 17, 2013 7:50 pm 


Top
  
 
PostPosted: Sun Feb 17, 2013 10:02 pm 
Offline
Shop Wrench
User avatar

Joined: Sat Nov 29, 2008 6:15 am
Posts: 710
There's a tool to replace the blade spring now. Not sure if its available directly to shops, but outside reps all have them.

_________________
"Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius -- and a lot of courage -- to move in the opposite direction."


Top
 Profile  
 
PostPosted: Sun Feb 17, 2013 10:35 pm 
Offline

Joined: Tue Nov 04, 2008 6:44 pm
Posts: 230
Mine cracked in a similar way. There's a post about it if you have a search. Look service (UK) was excellent. They sent me a new pair within a week.


Top
 Profile  
 
PostPosted: Mon Feb 18, 2013 2:50 am 
Offline

Joined: Sun Nov 04, 2012 11:36 am
Posts: 71
Been using Blade Ti's for quite a bit of time and I'm a heavy bloke. you can try the place where you bought it for the warranty info.

_________________
http://www.roadiemanila.com


Top
 Profile  
 
PostPosted: Mon Feb 18, 2013 3:03 am 
Offline
User avatar

Joined: Tue Jul 14, 2009 11:59 am
Posts: 108
Location: Australia
Had one of the blades start to delaminate after 15'000 km and also one pedal body near the engagement mechanism crack. On speedplays now 8-)

Sent from my HTC One XL using Tapatalk 2

_________________
N+1 It Never Stops


Top
 Profile  
 
PostPosted: Tue Feb 19, 2013 6:29 am 
Offline

Joined: Mon Jul 18, 2011 7:25 am
Posts: 62
I stripped the spindle on my Blade ti's and was given a new set under warranty. I had them for 8 months however, I'm not sure of their warranty period?

My LBS sent them in and I feel their good relationship may have played a roll in LOOK granting the warranty? I was told they are fairly liberal towards customer satisfaction if that helps. It can't hurt to try! Hope it goes well...


Top
 Profile  
 
PostPosted: Tue Feb 19, 2013 12:20 pm 
Offline

Joined: Sun Jul 13, 2008 10:37 pm
Posts: 66
Location: Los Angeles
My friend and I both had a blade crack on a pedal at roughly the same time.

He took them to a local shop who shipped them back to Look for us. Look installed new blades in each pedal and we had both sets back in under two days.

Probably helped that Look North America was in the same metropolitan area, but still amazed on the turn around.

I had terrible Campagnolo service a few years ago and just assumed every cycling company takes a few months to send back a replacement.


Top
 Profile  
 
PostPosted: Tue Feb 19, 2013 4:02 pm 
Offline

Joined: Tue Mar 15, 2005 2:43 am
Posts: 559
Location: The 'Dena
Yes had the same thing happen.. warranty

These pedals are light but i have had too many probs, this, a broken spring/ blade and a lot of play in the spindle/bearing.

Dura ace...


Top
 Profile  
 
PostPosted: Wed Feb 20, 2013 10:19 pm 
Offline
User avatar

Joined: Tue Jul 14, 2009 11:59 am
Posts: 108
Location: Australia
The bearings in these pedals are also quite cheap looking

Sent from my HTC One XL using Tapatalk 2

_________________
N+1 It Never Stops


Top
 Profile  
 
PostPosted: Thu Feb 21, 2013 6:46 am 
Offline

Joined: Sun Apr 04, 2010 10:27 am
Posts: 41
Location: Sydney
One of my blades has cracked too, but only a hairline and seems to be holding up.
I tried to get a replacement blade here in OZ. The importer, and nearly every shop
I called, basically told me it wasn't replaceable and to buy a new set. :shock:
No I didn't buy the pedals at my LBS, but with service like this no wonder.


Top
 Profile  
 
PostPosted: Thu Feb 21, 2013 1:24 pm 
Offline

Joined: Sat Nov 05, 2011 4:37 am
Posts: 133
Location: Perth W.A
Hey mate , I am on my second set of Ti Blades 16nm
The blade on my right leg snapped mid stroke going up hill and threw me ... put it into the shop and they asked if I had hit it with a hammer ....
Look dealer replaced it no questions asked ....

_________________
2012 KUOTA KOM Team Edition Campag SR11 .....My mistress
2012 RIDLEY HELIUM being built up ....


Top
 Profile  
 
PostPosted: Thu Feb 21, 2013 5:30 pm 
Offline

Joined: Tue Mar 15, 2005 2:43 am
Posts: 559
Location: The 'Dena
Yes .. had the blade break got that fixed.. had the same piece as the OP crack they replaced that.. then spindle's rattle and have a lot of play in the body...no good. 3 strikes your out !
Switched to Dura Ace..


Top
 Profile  
 
PostPosted: Tue May 28, 2013 6:54 pm 
Offline
User avatar

Joined: Sat Dec 04, 2010 5:31 pm
Posts: 347
A thread was running here on WW months ago on the topic of cracks developing at the base of the carbon body adjoining the axle in Keo Carbon Blades. I couldn't tell if this was a common problem or a rare one, but I decided to replace my Speedplays with the Keo Carbon pedals because of annoying lateral rocking motion which did not resolve with new Speedplay cleats.

Anyway, I used the Keo pedals (but did not abuse them) for 15 months and then one of the Blades cracked at the usual spot. Very disappointing and, I presume, indicative of a design flaw. Regardless, Competitive Cyclist (a company that's given me consistently outstanding customer service over many years) immediately and graciously offered to replace them at no charge.

I like the Blades sufficiently to try them once again. They are really nice pedals. So, with that sad vignette in mind, any consensus on this issue? Other problems with these?

KAC


Top
 Profile  
 
Posted: Tue May 28, 2013 6:54 pm 


Top
  
 
PostPosted: Tue May 28, 2013 7:48 pm 
Offline
User avatar

Joined: Sat Jun 19, 2010 8:21 pm
Posts: 440
Location: Zürich, Switzerland
Get normal kéos instead

_________________
Hucken The Fard Up !
Colnagos : C50 ST01 - Master 30th AD10 - C40 Mapei WC


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 16 posts ] 
Go to page 1, 2  Next


Who is online

Users browsing this forum: Bing [Bot], Frankie - B, Franklin, Google [Bot], Google Adsense [Bot], iamalex, ITTY, mnmasotto, rmerka, Yahoo [Bot] and 45 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

   Similar Topics   Author   Replies   Views   Last post 
There are no new unread posts for this topic. is it crack???

in Road

mastaYD

1

435

Tue Aug 05, 2014 3:21 pm

Stolichnaya View the latest post

There are no new unread posts for this topic. Paint or Frame Crack

in Road

LoggingMiles

10

411

Mon Aug 18, 2014 8:46 am

Mattias Hellöre View the latest post

There are no new unread posts for this topic. Top Tube Crack - Super-X Hi-Mod?

in Road

tojnom

5

939

Tue Apr 15, 2014 1:10 am

tojnom View the latest post

There are no new unread posts for this topic. I think my Tarmac comp frame has a crack?

in Road

merlinxlm

12

1133

Sat May 24, 2014 10:35 pm

Powerful Pete View the latest post

There are no new unread posts for this topic. Cervelo rear drop out crack repair

in Road

Riccfs

4

960

Tue Oct 08, 2013 12:26 pm

em3 View the latest post


It is currently Tue Sep 30, 2014 5:25 pm

All times are UTC + 1 hour




Advertising   –  FAQ   –  Contact   –  Convert   –  About

© Weight Weenies 2000-2013
hosted by starbike.com


How to get rid of these ads? Just register!


Powered by phpBB