HOT: Active* forum members generally gain 5% discount at starbike.com store!
Weight Weenies
* FAQ    * Search    * Trending Topics
* Login   * Register
HOME Listings Articles FAQ Contact About




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Sun Oct 14, 2012 5:06 am 
Offline

Joined: Tue Dec 02, 2008 4:21 am
Posts: 277
I've got a mechanical issue that I'd like to pose to you all here.

I've got a Specialized Tarmac Sl2 built with Campagnolo Neutrons, Super Record dual pivot brakes with wet weather salmon brake pads. I've had this set up pretty much since March, no falls and realistically all my riding has been on nice dry roads but about a month ago now I've noticed my front brake begin to judder when slowing down from >25mph but stops around 15-ish.

My wheels do have some quite a bit of miles in them, but feeling the braking surface, there is really no concave surface. I've checked to make sure everything is tightened down and nothing is really lose. I've cleaned off the braking surface and pads, still have the judder. I've changed out cables and housing, still nothing.

Has anyone experienced this and/or have a remedy?


Top
 Profile  
 
Posted: Sun Oct 14, 2012 5:06 am 


Top
  
 
PostPosted: Sun Oct 14, 2012 5:30 am 
Offline
User avatar

Joined: Mon Jan 23, 2006 6:35 am
Posts: 5014
Location: New York
Check your head set.

_________________
I never took drugs to improve my performance at any time. I will be willing to stick my finger into a polygraph test if anyone with big media pull wants to take issue. If you buy a signed poster now it will not be tarnished later. --Graeme Obree


Top
 Profile  
 
PostPosted: Sun Oct 14, 2012 5:59 am 
Offline
in the industry
User avatar

Joined: Sun Jul 29, 2012 2:59 pm
Posts: 626
Location: Ruidoso, NM
Headset... brake bolt.

_________________
formerly rruff...


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 


Who is online

Users browsing this forum: Baidu [Spider], Bing [Bot], Google [Bot], jb, jooo, RustySpokes, stevec1975, youngs_modulus and 84 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

   Similar Topics   Author   Replies   Views   Last post 
There are no new unread posts for this topic. Litespeed Archon T1 ROTOR & Ultegra front mech issue

in Road

choplee

13

940

Fri Dec 27, 2013 11:00 am

choplee View the latest post

There are no new unread posts for this topic. Which front brake for a Pinarello Graal and who stocks them?

in Road

puffingbilly

1

346

Tue Feb 25, 2014 9:37 pm

bmxbandit View the latest post

There are no new unread posts for this topic. DT 240S Freehub Issue

in Road

ultimobici

11

886

Tue Nov 05, 2013 7:15 am

ultimobici View the latest post

There are no new unread posts for this topic. Installing 6870 Di2 Issue

in Road

Carrots

5

576

Wed Jun 04, 2014 8:43 pm

tnc1970 View the latest post

There are no new unread posts for this topic. Selle Italia SLR Flow carbonio issue or ok?

in Road

aspms

8

923

Tue Mar 25, 2014 6:09 pm

aspms View the latest post


It is currently Wed Aug 20, 2014 4:01 pm

All times are UTC + 1 hour




Advertising   –  FAQ   –  Contact   –  Convert   –  About

© Weight Weenies 2000-2013
hosted by starbike.com


How to get rid of these ads? Just register!


Powered by phpBB