HOT: Active* forum members generally gain 5% discount at starbike.com store!
Weight Weenies
* FAQ    * Search    * Trending Topics
* Login   * Register
HOME Listings Articles FAQ Contact About




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Sun Oct 14, 2012 5:06 am 
Offline

Joined: Tue Dec 02, 2008 4:21 am
Posts: 278
I've got a mechanical issue that I'd like to pose to you all here.

I've got a Specialized Tarmac Sl2 built with Campagnolo Neutrons, Super Record dual pivot brakes with wet weather salmon brake pads. I've had this set up pretty much since March, no falls and realistically all my riding has been on nice dry roads but about a month ago now I've noticed my front brake begin to judder when slowing down from >25mph but stops around 15-ish.

My wheels do have some quite a bit of miles in them, but feeling the braking surface, there is really no concave surface. I've checked to make sure everything is tightened down and nothing is really lose. I've cleaned off the braking surface and pads, still have the judder. I've changed out cables and housing, still nothing.

Has anyone experienced this and/or have a remedy?


Top
 Profile  
 
PostPosted: Sun Oct 14, 2012 5:30 am 
Offline
User avatar

Joined: Mon Jan 23, 2006 6:35 am
Posts: 5020
Location: New York
Check your head set.

_________________
I never took drugs to improve my performance at any time. I will be willing to stick my finger into a polygraph test if anyone with big media pull wants to take issue. If you buy a signed poster now it will not be tarnished later. --Graeme Obree


Top
 Profile  
 
Posted: Sun Oct 14, 2012 5:30 am 


Top
  
 
PostPosted: Sun Oct 14, 2012 5:59 am 
Offline
in the industry
User avatar

Joined: Sun Jul 29, 2012 2:59 pm
Posts: 634
Location: Ruidoso, NM
Headset... brake bolt.

_________________
formerly rruff...


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 


Who is online

Users browsing this forum: Bing [Bot], CrossRob, dfischer1, duckson and 32 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

   Similar Topics   Author   Replies   Views   Last post 
There are no new unread posts for this topic. Dura ace 7900 front brake installation issue

in Road

amey

4

274

Wed Sep 03, 2014 1:31 pm

amey View the latest post

There are no new unread posts for this topic. Issue with Di2 Front Derailleur

in Road

AndreLM

11

652

Thu Sep 11, 2014 1:22 am

AndreLM View the latest post

There are no new unread posts for this topic. Litespeed Archon T1 ROTOR & Ultegra front mech issue

in Road

choplee

13

1191

Fri Dec 27, 2013 11:00 am

choplee View the latest post

There are no new unread posts for this topic. Attachment(s) 25mm tyre clearance issue with Ultegra 6800 rear brake

in Road

martinko

14

1579

Fri Sep 19, 2014 2:10 pm

ricks123 View the latest post

There are no new unread posts for this topic. Which front brake for a Pinarello Graal and who stocks them?

in Road

puffingbilly

1

421

Tue Feb 25, 2014 9:37 pm

bmxbandit View the latest post


It is currently Fri Nov 28, 2014 7:15 pm

All times are UTC + 1 hour




Advertising   –  FAQ   –  Contact   –  Convert   –  About

© Weight Weenies 2000-2013
hosted by starbike.com


How to get rid of these ads? Just register!


Powered by phpBB