SRAM Red 2012 Shifter broken?

Discuss light weight issues concerning road bikes & parts.
Post Reply
raiderr
Posts: 44
Joined: Thu Mar 11, 2010 6:18 pm

by raiderr

I have been running new Red shifters with old front derailleur, mainly because I read that there were some clearance issues when not having a 2012 red crank, and now I noticed that there was something wrong with the shifter that pulls front derailleurs cable.

The shifter just doesn't want to pull enough cable in like it use to, that the front derailleur would change to big chainring. So you are just stuck on the small ring. It just seems like its lazy or something, it pulls little bit not nearly enough so that it would change to the big chainring.

Has anyone else experienced this or heard of this? Anything you can do about it? Kinda sucks paying 400 euros for shifters and then 4 months later they are smashed.

Guess I just have to ride my old trusty Rival shifters for a while.

by Weenie


aaric
Posts: 439
Joined: Thu Jun 09, 2011 4:10 pm

by aaric

I'll ask the obvious: have you verified the cable hasn't slipped or stretched, and is seated properly in the shifter?


If that's not the problem, SRAM should warranty it if its 4 months old.

madmole
Posts: 138
Joined: Thu Nov 17, 2011 4:29 pm

by madmole

High limit screw set wrong?
Cervelo S3 2011. Blinged 6.718 Kg

raiderr
Posts: 44
Joined: Thu Mar 11, 2010 6:18 pm

by raiderr

aaric wrote:I'll ask the obvious: have you verified the cable hasn't slipped or stretched, and is seated properly in the shifter?


If that's not the problem, SRAM should warranty it if its 4 months old.

It did not seem to have slipped or stretched, will check it again tomorrow when I have more time. And yes shifters are only barely just 4 months old.

NWSAlpine
Posts: 296
Joined: Fri May 18, 2012 7:11 pm
Location: FL

by NWSAlpine

I would re-do the tension because along with potentially slipping the ferules might have not been fully seated. I have seen this happen on a new install before if the installer isn't careful.

BTW I'm running the new shifters and FD on a force crank with praxis rings (53/39) and working perfectly. No rub in any combo.

NoMütze
Posts: 54
Joined: Tue Jun 07, 2005 7:39 am
Location: austria

by NoMütze

Hi,

i changed my SRAM Red setup similar to you...
going vom 2010 RED shifters to the new designed ones and running the old FD.
Now what i experienced was that the FD cable needed a "playless" mounting in the lower
with a rather high tension (no hang loose), well - what else! would somebody say
and even then, shifting up, the final "click" came late...so to say...with more force needed then before (old/old).
the fear of breaking something inside the shifters came to my mind as well and finally i went for the
new yaw FD ....and this is definitly an upgrade in front shifting performance!
very smooth!!
so i would suggest: "go for the new FD!"

by Weenie


User avatar
ajh
Posts: 577
Joined: Sun Oct 24, 2004 1:41 am
Location: Toronto, Canada
Contact:

by ajh

I have an extra front derail

Pm if you want to buy it

I also have an extra compact new red GXP crank

Post Reply
  • Similar Topics
    Replies
    Views
    Last post