DA DI2 RD weird shifting-solution?

Discuss light weight issues concerning road bikes & parts.
Post Reply
el condor
Posts: 524
Joined: Sun Jan 16, 2005 1:52 pm
Location: Switzerland

by el condor

Just had my first race on the new tt rig today equipped with Dura Ace di2. Before the race I went to check all the gears, but weird stuff happened with the RD, when on the big ring and shifting down to the smallest cog (11t) it sort of works but then when shifting up again one cog it shifts automatically all the way up to the biggest (23t) stays there a second and shifts a bit down to the middle of the cassette and both lights on the control box blink red a few seconds.
I tried everything and have no clue. I bought the derailleur used but it seems to work-just not always :-). when pressing the button on the control box to fine tune the RD it some times works and sometimes not and both lights blink red a few times. Can't find this light pattern in the di2 manual. Any recommendations?
Thanks

by Weenie


TerribleCadence
Posts: 202
Joined: Tue Jun 28, 2011 4:33 pm
Location: United Kingdom

by TerribleCadence

Best solution, go to a LBS that has the diagnostics unit and let a mechanic work out what is wrong.
FELT AR0 Now sold.
CAAD10 Force 22, Quarq, Ksyrium SLR
LOOK 695 Light, Force22, Zipp 303.

thisisatest
Shop Owner
Posts: 1980
Joined: Sat Jun 13, 2009 4:02 am
Location: NoVA/DC

by thisisatest

the part when the derailleur shifts through all the gears, and then ends up in the middle gear, sounds a lot like the "reset" mode after a crash. you would hold down the button on the junction box. light would turn red, and if you keep holding down the button, the derailleur shifts all the way to the hardest gear, then all the way to the easiest gear, then it may go to the middle gears (cant remember). because of that, my first guess is the front wire or junction box may be the culprit.
easiest way to test without the diagnostics box (or even with it, really) is to try with a different derailleur, even one on a friend's bike. if all is good, try a different front wire, again, even if it's on a friend's bike. as long as yours is propped up you can test it.
good luck.

el condor
Posts: 524
Joined: Sun Jan 16, 2005 1:52 pm
Location: Switzerland

by el condor

Thanks for the help, I will try to hook up the system to another bike to see if it's the cable or the RD.
Would have to check who had a diagnostics device as I don't think there's a shop in my city that has one.

el condor
Posts: 524
Joined: Sun Jan 16, 2005 1:52 pm
Location: Switzerland

by el condor

thisisatest wrote:the part when the derailleur shifts through all the gears, and then ends up in the middle gear, sounds a lot like the "reset" mode after a crash. you would hold down the button on the junction box. light would turn red, and if you keep holding down the button, the derailleur shifts all the way to the hardest gear, then all the way to the easiest gear, then it may go to the middle gears (cant remember). because of that, my first guess is the front wire or junction box may be the culprit.
easiest way to test without the diagnostics box (or even with it, really) is to try with a different derailleur, even one on a friend's bike. if all is good, try a different front wire, again, even if it's on a friend's bike. as long as yours is propped up you can test it.
good luck.


So far I've put a new front cable, the one with the control box and the problem persists, what surprises me is the fact that on the inner metal plate of the parallelogram of the RD it's stamped "PROTOTYPE", could it be that this is a pre-series production with the often usual problems??

Johhny Bravo
Posts: 76
Joined: Mon Oct 20, 2008 5:06 am
Location: Minas Gerais, Brazil

by Johhny Bravo

Ride safe!
Eduardo
2011 Look 695 SR

by Weenie


drmutley
Posts: 344
Joined: Fri Feb 11, 2011 4:23 am

by drmutley

Try shooting an email to shimano support and see what they suggest? As it seems a pretty common occurrence...

Post Reply
  • Similar Topics
    Replies
    Views
    Last post