Weight Weenies
* FAQ    * Search    * Trending Topics
* Login   * Register
HOME Listings Blog NEW Galleries NEW FAQ Contact About Impressum
It is currently Sat Oct 01, 2016 5:55 am
Recently the board software has been updated and there are some known bugs/failures:
- Avatars are currently not being displayed ✔ FIXED
- Tapatalk connection is currently broken ✔ FIXED
- Avatars cannot be uploaded ✔ FIXED

Please note that we will soon do some changes in WW board template design in case to get a fully mobile/desktop responsiveness board!
If you find more errors please post it here: http://weightweenies.starbike.com/forum/viewtopic.php?f=7&t=139062


All times are UTC+01:00





Post new topic  Reply to topic  [ 8 posts ] 
Author Message
PostPosted: Sat Jul 07, 2012 3:34 pm 
Offline

Joined: Tue Jan 27, 2009 8:19 pm
Posts: 363
Just got a new Powertap G3 hub, and I wanted to check that the firmware was up to date. Downloaded the PowerAgent software and removed the power cap from the hub.

First source of confusion was the discrepancies between the G3 manual and advice provided online and in the PowerAgent software itself. The manual doesn't mention anything about removing the battery before connecting the powercap to the PC, and the FAQs on the website imply that the battery should still be in place (it mentions not leaving it connected for too long in case you drain the battery). However, other 3rd party advice I found online suggests that it is necessary to remove the battery, most of the time the powercap isn't recognised by the computer unless you do this, and after updating the firmware the PowerAgent software warns you to disconnect the power cap from the computer before re-inserting the battery! So I found out the hard way that removing the battery first is necessary and am hoping nothing has been damaged as a result of not doing this the first time...

Secondly, I can't figure out if the firmware update has been implemented correctly. When I first connected the powercap, PowerAgent told me I had v. 16.000 installed and allowed me to update to v. 16.021. Afterwards, when I check the status it tells me that I have the latest version (16.021) installed. However, every time I disconnect the powercap from the computer and reconnect it, PowerAgent tells me I still have the older firmware and updates it again... How do I really know what firmware I have installed?


Top
   
PostPosted: Wed Feb 25, 2015 9:18 pm 
Offline

Joined: Wed Mar 17, 2010 12:04 am
Posts: 103
Did you ever sort this?

Ive done the update several times, but it each time I unplug and plug it back it says that it still needs the update.

Its like its doing the update but its not getting saved.


Top
   
Posted: Wed Feb 25, 2015 9:18 pm 


Top
   
 
PostPosted: Wed Feb 25, 2015 11:40 pm 
Offline

Joined: Tue Jan 27, 2009 8:19 pm
Posts: 363
Yup, I think that's just a peculiarity of the software. It often/usually asks you to update even if you already have the latest version. The definitive guide to updating seems to be here:

http://www.powertap.com/pages/powertap-hub-wheel-faq

The best way to check what version of the software you have in the G3 seems to be with a 3rd party device such as a Garmin. On the Garmin 800 if you go to ANT+Power => Sensor Details => About Sensor it will list "SW Version" at the bottom. The decimal point is in the wrong place and it only includes the last two digits, but it tells you what version you have. Mine currently says "5.800", which presumably equals Powertap software version 15.058.


Top
   
PostPosted: Thu Feb 26, 2015 6:17 am 
Offline

Joined: Mon Jul 08, 2013 3:38 am
Posts: 61
I seem to have the opposite problem. I want to update my firmware but it says that I already have the latest firmware. I can't have the latest firmware because it was released march 2014 and I bought the hub in Jan 2014. I have emailed Powertap but I'm yet to get a solution from them. Anyone else ran into this problem?

FWIW: Tried both on a mac and a PC. Same result.


Top
   
PostPosted: Thu Feb 26, 2015 11:42 am 
Offline
User avatar

Joined: Wed Apr 25, 2007 10:23 am
Posts: 1071
Location: Pack filler
Have you got the latest version of poweragent?
If not do that first.

Then once you've got it open, wake the hub up by spinning it, and then remove the powercap BEFORE it goes to sleep again. Remove battery.
Connect to PC and update firmware.
Disconnect and reinsert battery and powercap


never had any hassle (at least with this part of powertap :wink: )

_________________
Official cafe stop tester


Top
   
PostPosted: Fri Feb 27, 2015 6:12 am 
Offline

Joined: Mon Jul 08, 2013 3:38 am
Posts: 61
Yup, got the latest version of poweragent. How long before it goes to sleep? I did it pretty much immediately (< 1min) after I woke the device. Tried again. No luck.


Top
   
PostPosted: Sat Feb 28, 2015 7:59 am 
Offline

Joined: Sun Nov 22, 2009 7:49 am
Posts: 58
Location: Helsinki, Finland
I had to repeat the firmware update process several [1] times before the firmware was there. This process was:

1) remove battery
2) plug the PowerCap into PC w/ newest software
3) upload new FW with PowerAgent
4) disconnect PowerCap and wait for 15 - 20 seconds

And even then the PowerAgent was unable to show the new FW version number. I confirmed the FW from my Garmin Edge 500 which shows it in the "Sensor Details" view. Sold the PowerTap wheel and now using Power2Max and Rotor Power.

[1] More like ten times.

EDIT: fixed typo.

_________________
Stanga Racing
http://www.tonitoni.fi/


Top
   
PostPosted: Tue Mar 03, 2015 5:14 am 
Offline

Joined: Mon Jul 08, 2013 3:38 am
Posts: 61
I could finally do it with help from Powertap customer service. I had to downgrade to an older Java version to get it to work. Yet to ride with the new firmware but hoping it all works out well!


Top
   
Posted: Tue Mar 03, 2015 5:14 am 


Top
   
 
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 8 posts ] 

   Similar Topics   Author   Replies   Views   Last post 
There are no new unread posts for this topic. Updating EPS from V2 to V3?

in Road

csteenbe

8

944

Wed Mar 30, 2016 12:52 am

ferrarista View the latest post

There are no new unread posts for this topic. DI2 firmware Query after changing battery

in Road

frankp2112

6

352

Sat Sep 03, 2016 8:02 pm

goodboyr View the latest post

There are no new unread posts for this topic. Shimano 9070 firmware updates for customizing ?

in Road

ironman1

0

157

Sun Sep 04, 2016 10:29 pm

ironman1 View the latest post

There are no new unread posts for this topic. Shimano 9070 firmware updates for customizing ?

in Road

ironman1

9

619

Fri Sep 16, 2016 2:46 pm

ironman1 View the latest post

There are no new unread posts for this topic. Shimano updated firmware for Dfly reduces power consumption

in Road

goodboyr

3

533

Sat Apr 23, 2016 8:32 am

superdx View the latest post


All times are UTC+01:00


Who is online

Users browsing this forum: Bing [Bot], Exabot [Bot], Google [Bot], GT8, Kam0916, pdlpsher1, Yahoo [Bot] and 26 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited