Weight Weenies
* FAQ    * Search    * Trending Topics
* Login   * Register
HOME Listings Blog NEW Galleries NEW FAQ Contact About
It is currently Sun May 01, 2016 6:54 pm
Recently the board software has been updated and there are some known bugs/failures:
- Avatars are currently not being displayed ✔ FIXED
- Tapatalk connection is currently broken ✔ FIXED

If you find more errors please post it here: http://weightweenies.starbike.com/forum/viewtopic.php?f=7&t=139062


All times are UTC+01:00





Post new topic  Reply to topic  [ 21 posts ]  Go to page Previous 1 2
Author Message
PostPosted: Sun Jun 03, 2012 6:25 pm 
Offline

Joined: Tue Mar 01, 2011 12:28 pm
Posts: 30
I think that what Gregorio said is correct. Same thing happened to one of my Speedplay cleats a few months ago (replaced under warranty).


Top
   
PostPosted: Mon Jun 04, 2012 3:39 am 
Offline

Joined: Sat Aug 27, 2005 5:57 am
Posts: 792
Location: mOntreal
Ach! Quit cher whinin'! I was at a race today and some poor guy pulled his cleat right off his shoe!!

_________________
it's actually possible to come to the conclusion even before realising it makes no sense at all
-
tymon_tm


Top
   
PostPosted: Mon Jun 04, 2012 3:51 am 
Offline
Shop Owner

Joined: Sat Jun 13, 2009 4:02 am
Posts: 1980
Location: NoVA/DC
your cleats look fine, they are the right ones, dont look broken, but the wear marks on your steel protector seem a little odd. how old are your pedals? could be worn bowties as mentioned, could be worn edges on the pedal bodies allowing angular movement. i would check that the cleats sit square. by that i mean that if you look at the front of your shoes head-on, the front of the cleat should be on the same plane as the rear of the cleat. if there's a twist, correct it with the "extra shim" provided. good luck.


Top
   
PostPosted: Mon Jun 04, 2012 5:05 pm 
Offline

Joined: Mon Jan 24, 2011 8:09 pm
Posts: 871
Gregorio wrote:
Looks like the "c" metal spring is broken in the picture. (at the bottom of picture) looks like the end of it has broken off.
Excessive wear on the bow ties edge can cause this to happen quickly.


Not missing, that is correct.

Also, ensure the c-clip has the * side up, they are tapered slightly on one side for entrance into the pedal, if you have them upside down, I would assume this would allow for them to unclip easily, even without twisting.


Image


Top
   
PostPosted: Mon Jun 04, 2012 5:21 pm 
Offline

Joined: Thu Jun 09, 2011 4:10 pm
Posts: 431
iscarrr wrote:
Is using loctite key here?


I've forgotten to locktite the screws on my cleats 3 times after adjusting them. Each time has resulted in lost screws. Really loose is relative, but you can't crank down on them much, or the retention ring will bind in the cleat - its entirely possible that the ring is being pinched by the plastic, and not functioning properly.


Top
   
PostPosted: Mon Jun 04, 2012 6:16 pm 
Offline
User avatar

Joined: Sat Aug 29, 2009 4:30 pm
Posts: 1861
Gregorio wrote:
Looks like the "c" metal spring is broken in the picture. (at the bottom of picture) looks like the end of it has broken off.
Excessive wear on the bow ties edge can cause this to happen quickly.

I just checked mine for comparison, and I don't think it is broken, just hidden due to the rotation angle.

The original picture isn't clear-enough (lighting/shadow) to be conclusive, but the C-clip may be upside down ? The bevel should be visible from the outside to ease entry.

I have been using Speedplays for a lot of years and never pulled out even once. But I suppose some people flail their ankles more than others.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 21 posts ]  Go to page Previous 1 2

   Similar Topics   Author   Replies   Views   Last post 
There are no new unread posts for this topic. Giant TCR alu bearing races in bottom bracket

[ Go to page: 1 2 ]

in Road

jorisee01

24

755

Wed Dec 16, 2015 10:51 pm

jorisee01 View the latest post

There are no new unread posts for this topic. Thinking about running 1x10 for youth races

in Road

emcardle

11

841

Sun Jul 12, 2015 6:40 pm

LouisN View the latest post


All times are UTC+01:00


Who is online

Users browsing this forum: DeRibble, Yahoo [Bot] and 40 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited