HOT: Active* forum members generally gain 5% discount at starbike.com store!
Weight Weenies
* FAQ    * Search    * Trending Topics
* Login   * Register
HOME Listings Articles FAQ Contact About




Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Thu Dec 12, 2013 2:03 am 
Offline

Joined: Thu Dec 12, 2013 2:02 am
Posts: 1
I've had my 2013 Felt DA4 for about a month now, and am concerned over the lack of rear brake stopping power. Even when the brake lever is full activated (pulled so far its touching the grips of the pursuit bar) there is almost no stopping power. It almost feels like there is no tension on the cable when you pull the lever. My LBS keeps telling me that it's "just the way the bike was made" and there is nothing they can do about increasing the stopping power. As it is right now, it makes the bike exceptionally dangerous to ride on anything but level ground.

I know there are (and have read through) threads where users have complaints that the brakes don't return to the "neutral" position, but my brakes feel like they don't even move to an "activated" position at all.

Aside from this issue the bike is great, and for one of Felt's "higher end" model ranges it seems crazy this is even an issue.

Has anyone else encountered very spongy/non-responsive brakes? Does anyone have any suggestions?


Top
 Profile  
 
PostPosted: Thu Dec 12, 2013 3:08 am 
Offline

Joined: Thu Dec 05, 2013 3:37 am
Posts: 146
Have you adjusted the brakes yourself?

Sent from my Nexus 7 using Tapatalk


Top
 Profile  
 
Posted: Thu Dec 12, 2013 3:08 am 


Top
  
 
PostPosted: Thu Dec 12, 2013 6:50 am 
Offline

Joined: Sat Nov 10, 2007 9:51 pm
Posts: 292
undo the cable lock bolt, push the brake pads onto the rim and hold them their, then pull the cable through and re-tighten the cable lock bolt


Top
 Profile  
 
PostPosted: Thu Dec 12, 2013 9:25 am 
Offline

Joined: Sat Mar 16, 2013 9:21 am
Posts: 46
Two things. First, you keep saying it feels like there's no tension on the cable, like the brake itself doesn't move. Did you check this? Do the brake pads actually come into contact with the rim when you pull the lever? If yes, when do they touch the rim - how far does the lever have to move before the pads come into action?

Second, why would a bicycle with a functioning front brake be extremely dangerous to ride on anything but level ground? Or are there problems with the front brake too?


Top
 Profile  
 
PostPosted: Fri Dec 13, 2013 12:44 pm 
Offline

Joined: Fri Jan 27, 2006 1:38 pm
Posts: 570
Location: Greater Pittsburgh
You need to remove the wheel and flip the bike upside down to get good access to the brake. Disconnect the cable. Each brake arm is individually connect to the frame through a center bolt, unscrew that bolt, but be careful, there's a spring under each brake. Once you have this removed, clean all surfaces (brake pin and the brake itself), and relube everything. The spring has two "arms", one that connects to the hole in the brake and one that connects to one of the 3 holes in the frame. You need to move the spring into the 2nd or 3rd position, which will increase the tension that spring is under, and bolt the brakes back on with the center screw. Make sure your brake housing is not too long and pushes the brake to either side, or too short, which pulls the brake to one side.

_________________
"Suddenly the thought struck me; my floor is someone elses ceiling" - Nils Ferlin


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 


Who is online

Users browsing this forum: Bing [Bot], RChevalier, weeni, Yahoo [Bot] and 49 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

   Similar Topics   Author   Replies   Views   Last post 
There are no new unread posts for this topic. 2013 SRAM Red rear derailleurs recalled.

in Road

BikeAnon

4

1081

Tue Mar 25, 2014 9:31 am

Juanmoretime View the latest post

There are no new unread posts for this topic. pinarello dogma 60.1 rear brake

in Road

Post Man Pat

4

895

Wed Oct 02, 2013 12:54 pm

scamper View the latest post

There are no new unread posts for this topic. Powertap 2.4 SL Not working..

in Road

addicted

6

664

Fri Aug 30, 2013 6:03 pm

addicted View the latest post

There are no new unread posts for this topic. Red front shifter not working in the cold.

in Road

Juanmoretime

9

702

Mon Oct 14, 2013 10:17 am

theremery View the latest post

There are no new unread posts for this topic. Felt F1 FRD 2014

[ Go to page: 1, 2, 3 ]

in Road

Wildman

37

4524

Fri Aug 01, 2014 5:05 am

SuperDave View the latest post


It is currently Thu Aug 21, 2014 5:54 am

All times are UTC + 1 hour




Advertising   –  FAQ   –  Contact   –  Convert   –  About

© Weight Weenies 2000-2013
hosted by starbike.com


How to get rid of these ads? Just register!


Powered by phpBB