Weight Weenies
* FAQ    * Search    * Trending Topics
* Login   * Register
HOME Listings Blog NEW Galleries NEW FAQ Contact About Impressum
It is currently Sun Sep 25, 2016 4:47 pm
Recently the board software has been updated and there are some known bugs/failures:
- Avatars are currently not being displayed ✔ FIXED
- Tapatalk connection is currently broken ✔ FIXED
- Avatars cannot be uploaded ✔ FIXED

Please note that we will soon do some changes in WW board template design in case to get a fully mobile/desktop responsiveness board!
If you find more errors please post it here: http://weightweenies.starbike.com/forum/viewtopic.php?f=7&t=139062


All times are UTC+01:00




Post new topic  Reply to topic  [ 19 posts ]  Go to page Previous 1 2
Author Message
PostPosted: Wed Jul 02, 2014 4:17 pm 
Offline
User avatar

Joined: Wed Apr 09, 2014 8:08 pm
Posts: 222
Location: Bremerton, WA
Matches my experiences pretty closely. 2012 must have been a bad year for QC at Vittoria.

_________________
Moloko Plus 6.24 kg

"We haven't located us yet"


Top
   
Posted: Wed Jul 02, 2014 4:17 pm 


Top
   
 
PostPosted: Mon Jul 07, 2014 2:45 pm 
Offline

Joined: Mon Jan 24, 2011 8:09 pm
Posts: 918
My issue wasn't flats. The issue I found was just poorer and poorer QC with each purchase of tires the past few years. The valve area was real garbage, what a mess trying to get the valve to sit correctly when mounting and not causing a hop. Even doing some sanding of the carbon wheel valve area didn't help. The tape just seemed really poorly applied etc..

Found good deals on Veloflex at times, just buy 3-4 at a time, be done with it, real good quality/QC overall, ride has been very good/comparable as others.


Top
   
PostPosted: Fri Jul 11, 2014 7:34 am 
Offline

Joined: Wed Nov 10, 2004 8:20 pm
Posts: 109
Location: on the border
Hi,

want to update my previous opinion in this thread on SR's tubulars. Mine exploaded last saturday on the rear just after no more than one thousand km on it... Gone back to Conti competition again. Must be something wrong with them. Ride was great, but the quality is questionable now.


Top
   
PostPosted: Sun Jul 13, 2014 6:57 am 
Offline

Joined: Wed Nov 10, 2004 8:20 pm
Posts: 109
Location: on the border
"steel515" PM sent.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 19 posts ]  Go to page Previous 1 2

   Similar Topics   Author   Replies   Views   Last post 
There are no new unread posts for this topic. Question: Continental valve extenders with Vittoria Tubulars

in Everything wheels

nemeseri

3

117

Fri Aug 12, 2016 10:10 pm

nemeseri View the latest post

There are no new unread posts for this topic. Trek - no love on WW?

[ Go to page: 1 2 3 4 5 6 ]

in Road

Devon

80

10156

Thu Jan 14, 2016 7:58 pm

nemeseri View the latest post

There are no new unread posts for this topic. not much love for Litespeed T1SL?

in Road

addictR1

13

1477

Sun Apr 03, 2016 10:21 am

fromtrektocolnago View the latest post

There are no new unread posts for this topic. New Wheels - Love Some WW Opinions

in Everything wheels

FMB51

4

706

Sat Apr 09, 2016 12:41 am

mbrider View the latest post

There are no new unread posts for this topic. Vittoria TLR?

in Road

kulivontot

3

471

Tue Apr 19, 2016 6:30 am

ultimobici View the latest post


All times are UTC+01:00


Who is online

Users browsing this forum: Google [Bot] and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited