Look 695 SR with Dura-Ace Di2 9070 (New pic 4.9.2013)

Who are you (no off-topic talk please)

Moderator: Moderator Team

natiedean24
Posts: 366
Joined: Wed Jun 10, 2009 2:16 pm
Location: Austin, Texas
Contact:

by natiedean24

Thanks for taking such great pictures - awesome build!

RC856
Posts: 57
Joined: Wed Apr 11, 2012 12:37 pm

by RC856

Beautiful!
Love it :D

by Weenie


Jman
Posts: 84
Joined: Wed Jan 20, 2010 3:17 pm

by Jman

jvanv8 wrote:Great build... I need to get my hands on a Look...
How do you like the cranks & stem?

One thing that annoys me with the stem is while the stem is adjustable, it basically only goes up. That position I have it on is the lowest it goes. I dunno if there is technical reason why they can't go more negative but that upwards adjustability is IMO useless for most of their target audience.

biotin
Posts: 40
Joined: Tue Jun 21, 2011 8:34 am

by biotin

Did you change the stock spokes?

Imaking20
Posts: 1466
Joined: Fri Nov 18, 2011 5:19 am

by Imaking20

-_-
Current:
T2

Retired:
Blue | Project C6.0 | Felt AR FRD | Colnago C59 NERO | 2014 S-Works Tarmac | S-Works Venge | Wilier Cento Uno SL | Tarmac SL2

Jman
Posts: 84
Joined: Wed Jan 20, 2010 3:17 pm

by Jman

biotin wrote:Did you change the stock spokes?

Some joke I don't get...?:)

Jman
Posts: 84
Joined: Wed Jan 20, 2010 3:17 pm

by Jman

Imaking20 wrote:I'm interested to see what you come up with regarding the freewheel. Mine drags like crazy since I made the same swap - my LBS said "that's Mavic"

OK it seems that it's really up to the oil you put in there. I tried few lubes which worked for a very short while and after that started rubbing. Before I did two day 200km trip with my friend I took it apart once more and cleaned everything and then I putted Shimano Wet Lube in there. It seems to work now after two days of riding. Maybe I will have to order some of Pedro's Road Rage to make it really work properly. If someone can't tell me what would be the equivalent of that which I could by locally? Must be some basic oil you could get what that Pedro's stuff is?

Imaking20
Posts: 1466
Joined: Fri Nov 18, 2011 5:19 am

by Imaking20

I took mine apart, cleaned out all grease, and replaced with some synthetic motor oil. Much, much less drag.
Current:
T2

Retired:
Blue | Project C6.0 | Felt AR FRD | Colnago C59 NERO | 2014 S-Works Tarmac | S-Works Venge | Wilier Cento Uno SL | Tarmac SL2

Jman
Posts: 84
Joined: Wed Jan 20, 2010 3:17 pm

by Jman

Bought spare set of 24mm profile carbon wheels from Ebay. Added few pictures in first post.

User avatar
Fuchspk
Posts: 422
Joined: Tue Apr 10, 2007 7:38 pm
Location: Sweden

by Fuchspk

Looks really cool this bike, but just with the Mavic wheels!

locktopus
Posts: 175
Joined: Mon Oct 03, 2011 3:47 pm

by locktopus

I love this!

This looks so hot!
This Look's so hot!

goodboyr
Posts: 1388
Joined: Wed Jan 10, 2007 10:56 pm
Location: Canada

by goodboyr

Jman wrote:
Imaking20 wrote:I'm interested to see what you come up with regarding the freewheel. Mine drags like crazy since I made the same swap - my LBS said "that's Mavic"

OK it seems that it's really up to the oil you put in there. I tried few lubes which worked for a very short while and after that started rubbing. Before I did two day 200km trip with my friend I took it apart once more and cleaned everything and then I putted Shimano Wet Lube in there. It seems to work now after two days of riding. Maybe I will have to order some of Pedro's Road Rage to make it really work properly. If someone can't tell me what would be the equivalent of that which I could by locally? Must be some basic oil you could get what that Pedro's stuff is?


I've always used Mobil 1 synthetic 0w30 successfully.

Jman
Posts: 84
Joined: Wed Jan 20, 2010 3:17 pm

by Jman

goodboyr wrote:
Jman wrote:
Imaking20 wrote:I'm interested to see what you come up with regarding the freewheel. Mine drags like crazy since I made the same swap - my LBS said "that's Mavic"

OK it seems that it's really up to the oil you put in there. I tried few lubes which worked for a very short while and after that started rubbing. Before I did two day 200km trip with my friend I took it apart once more and cleaned everything and then I putted Shimano Wet Lube in there. It seems to work now after two days of riding. Maybe I will have to order some of Pedro's Road Rage to make it really work properly. If someone can't tell me what would be the equivalent of that which I could by locally? Must be some basic oil you could get what that Pedro's stuff is?


I've always used Mobil 1 synthetic 0w30 successfully.


Thx, must try that.

goodboyr
Posts: 1388
Joined: Wed Jan 10, 2007 10:56 pm
Location: Canada

by goodboyr

And make sure you put some oil on the rubber seal and the white bushing, not just pawl and teeth area.

by Weenie


Jman
Posts: 84
Joined: Wed Jan 20, 2010 3:17 pm

by Jman

goodboyr wrote:And make sure you put some oil on the rubber seal and the white bushing, not just pawl and teeth area.


Yep, done that.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post