HOT: Active* forum members generally gain 5% discount at starbike.com store!
Weight Weenies
* FAQ    * Search    * Trending Topics
* Login   * Register
HOME Listings Blog NEW Galleries NEW FAQ Contact About




Post new topic Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Thu Oct 28, 2010 7:38 am 
Offline
User avatar

Joined: Wed Feb 20, 2008 4:22 pm
Posts: 105
Location: Amber land
Hello,
I've got a problem with my Racing Ralph 2.1 UST. I've tried to mount them on my SLR rims, and both always blow off when I inflate 2-2.5 BAR. One tyre is slightly used, another brand new. Where can be a problem?

_________________
With style, petite, with style...


Top
 Profile  
 
Posted: Thu Oct 28, 2010 7:38 am 


Top
  
 
PostPosted: Thu Oct 28, 2010 7:27 pm 
Offline
User avatar

Joined: Fri Oct 23, 2009 5:33 pm
Posts: 71
Location: Belgrade, Serbia
painless wrote:
Hello,
I've got a problem with my Racing Ralph 2.1 UST. I've tried to mount them on my SLR rims, and both always blow off when I inflate 2-2.5 BAR. One tyre is slightly used, another brand new. Where can be a problem?


tires used with selant?
if yes, you must remove any trace of old selant on contact surface between tire and rim.

if no,
check riim


Top
 Profile  
 
PostPosted: Fri Oct 29, 2010 1:03 pm 
Offline
User avatar

Joined: Sun Dec 07, 2008 5:23 pm
Posts: 92
painless wrote:
Hello,
I've got a problem with my Racing Ralph 2.1 UST. I've tried to mount them on my SLR rims, and both always blow off when I inflate 2-2.5 BAR. One tyre is slightly used, another brand new. Where can be a problem?

IsnĀ“t it possible to inflate your tires to max recommended presure? Will the tires blow off while inflating and reaching pressure of 2-2,5BAR? Or you mean that when you inflate the tires to 2-2,5BAR they will blow off in a short time?
If this is the problem, try to inflate your tires to max pressure. It will find its possition on the rim. After 2 or 3 minutes decrease the pressure to your desired value.

_________________
MTB - Van Nicholas Zion
Road - Van Nicholas Euros


Top
 Profile  
 
PostPosted: Fri Oct 29, 2010 8:59 pm 
Offline
User avatar

Joined: Wed Feb 20, 2008 4:22 pm
Posts: 105
Location: Amber land
One ralph is used, other - new.
It looks I've done everything right. Soupy water, bead put in to the center groove. Then I try to inflate it. It starts to pop-op ant when it reaches preashure 1.5-2 BAR (sometimes 2.5 BAR) it blows off the rim before reaching the max preasure. Looks like these tyres are spoilaged... Some guys told me that these tyres only suitable for trash...

_________________
With style, petite, with style...


Top
 Profile  
 
PostPosted: Fri Oct 29, 2010 9:33 pm 
Offline
User avatar

Joined: Fri Oct 23, 2009 5:33 pm
Posts: 71
Location: Belgrade, Serbia
painless wrote:
Some guys told me that these tyres only suitable for trash...


...as Earth is flat...


Top
 Profile  
 
PostPosted: Sat Oct 30, 2010 1:58 pm 
Offline

Joined: Tue Oct 26, 2010 7:53 pm
Posts: 19
painless wrote:
Hello,
I've got a problem with my Racing Ralph 2.1 UST. I've tried to mount them on my SLR rims, and both always blow off when I inflate 2-2.5 BAR. One tyre is slightly used, another brand new. Where can be a problem?

have you tried to put soap on your tire bed? and make sure it pop on rim


Top
 Profile  
 
PostPosted: Sun Oct 31, 2010 12:36 pm 
Offline
User avatar

Joined: Wed Feb 20, 2008 4:22 pm
Posts: 105
Location: Amber land
yes, I;ve tried this procedure. I think the problem is in the bead :noidea:

_________________
With style, petite, with style...


Top
 Profile  
 
Posted: Sun Oct 31, 2010 12:36 pm 


Top
  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 


Who is online

Users browsing this forum: HaakonJohansen, MSNbot Media and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

   Similar Topics   Author   Replies   Views   Last post 
There are no new unread posts for this topic. sigma rox 10 mounting

in Road

Nelus

3

214

Wed Oct 07, 2015 1:14 pm

Nelus View the latest post

There are no new unread posts for this topic. Help. Derailleur mounting bolt stuck

in Road

GooseNest

5

285

Fri Aug 14, 2015 4:58 am

rmerka View the latest post

There are no new unread posts for this topic. Campagnolo Bora Ultra 35 CLINCHER tire mounting

in Everything wheels

Bourquek

8

266

Sun Feb 07, 2016 10:16 pm

Suwoni View the latest post

There are no new unread posts for this topic. Which factor play a role of tough tire mounting on wide rim?

[ Go to page: 1, 2 ]

in Road

mpulsiv

15

406

Thu Jan 28, 2016 11:57 pm

bm0p700f View the latest post

There are no new unread posts for this topic. Garmin problems

in Cycle Chat

Wonderman

10

772

Wed Sep 23, 2015 12:38 pm

bomber View the latest post


It is currently Tue Feb 09, 2016 9:42 pm

All times are UTC + 1 hour




Advertising   –  FAQ   –  Contact   –  Convert   –  About

© Weight Weenies 2000-2013
hosted by starbike.com


How to get rid of these ads? Just register!


Powered by phpBB