HOT: Active* forum members generally gain 5% discount at starbike.com store!
Weight Weenies
* FAQ    * Search    * Trending Topics
* Login   * Register
HOME Listings Blog NEW Articles FAQ Contact About




Post new topic Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Thu Oct 28, 2010 7:38 am 
Offline
User avatar

Joined: Wed Feb 20, 2008 4:22 pm
Posts: 105
Location: Amber land
Hello,
I've got a problem with my Racing Ralph 2.1 UST. I've tried to mount them on my SLR rims, and both always blow off when I inflate 2-2.5 BAR. One tyre is slightly used, another brand new. Where can be a problem?

_________________
With style, petite, with style...


Top
 Profile  
 
PostPosted: Thu Oct 28, 2010 7:27 pm 
Offline
User avatar

Joined: Fri Oct 23, 2009 5:33 pm
Posts: 71
Location: Belgrade, Serbia
painless wrote:
Hello,
I've got a problem with my Racing Ralph 2.1 UST. I've tried to mount them on my SLR rims, and both always blow off when I inflate 2-2.5 BAR. One tyre is slightly used, another brand new. Where can be a problem?


tires used with selant?
if yes, you must remove any trace of old selant on contact surface between tire and rim.

if no,
check riim


Top
 Profile  
 
Posted: Thu Oct 28, 2010 7:27 pm 


Top
  
 
PostPosted: Fri Oct 29, 2010 1:03 pm 
Offline
User avatar

Joined: Sun Dec 07, 2008 5:23 pm
Posts: 92
painless wrote:
Hello,
I've got a problem with my Racing Ralph 2.1 UST. I've tried to mount them on my SLR rims, and both always blow off when I inflate 2-2.5 BAR. One tyre is slightly used, another brand new. Where can be a problem?

IsnĀ“t it possible to inflate your tires to max recommended presure? Will the tires blow off while inflating and reaching pressure of 2-2,5BAR? Or you mean that when you inflate the tires to 2-2,5BAR they will blow off in a short time?
If this is the problem, try to inflate your tires to max pressure. It will find its possition on the rim. After 2 or 3 minutes decrease the pressure to your desired value.

_________________
MTB - Van Nicholas Zion
Road - Van Nicholas Euros


Top
 Profile  
 
PostPosted: Fri Oct 29, 2010 8:59 pm 
Offline
User avatar

Joined: Wed Feb 20, 2008 4:22 pm
Posts: 105
Location: Amber land
One ralph is used, other - new.
It looks I've done everything right. Soupy water, bead put in to the center groove. Then I try to inflate it. It starts to pop-op ant when it reaches preashure 1.5-2 BAR (sometimes 2.5 BAR) it blows off the rim before reaching the max preasure. Looks like these tyres are spoilaged... Some guys told me that these tyres only suitable for trash...

_________________
With style, petite, with style...


Top
 Profile  
 
PostPosted: Fri Oct 29, 2010 9:33 pm 
Offline
User avatar

Joined: Fri Oct 23, 2009 5:33 pm
Posts: 71
Location: Belgrade, Serbia
painless wrote:
Some guys told me that these tyres only suitable for trash...


...as Earth is flat...


Top
 Profile  
 
PostPosted: Sat Oct 30, 2010 1:58 pm 
Offline

Joined: Tue Oct 26, 2010 7:53 pm
Posts: 19
painless wrote:
Hello,
I've got a problem with my Racing Ralph 2.1 UST. I've tried to mount them on my SLR rims, and both always blow off when I inflate 2-2.5 BAR. One tyre is slightly used, another brand new. Where can be a problem?

have you tried to put soap on your tire bed? and make sure it pop on rim


Top
 Profile  
 
Posted: Sat Oct 30, 2010 1:58 pm 


Top
  
 
PostPosted: Sun Oct 31, 2010 12:36 pm 
Offline
User avatar

Joined: Wed Feb 20, 2008 4:22 pm
Posts: 105
Location: Amber land
yes, I;ve tried this procedure. I think the problem is in the bead :noidea:

_________________
With style, petite, with style...


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 


Who is online

Users browsing this forum: Bing [Bot] and 12 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

   Similar Topics   Author   Replies   Views   Last post 
There are no new unread posts for this topic. Attachment(s) Schwalbe Racing Ralph Evo LiteSkin 29 X 2.25 folding $55usd

in For sale - Pictures are mandatory 22-3-13

chrisMTB

0

89

Tue May 05, 2015 4:26 am

chrisMTB View the latest post

There are no new unread posts for this topic. Di2 Junction A box mounting options

in Road

prebsy

4

811

Fri Jul 04, 2014 3:58 pm

JamieL View the latest post

There are no new unread posts for this topic. Help with mounting Campagnolo canti brakes

in Cyclocross / Touring

dtddiver

2

344

Mon Aug 11, 2014 4:31 pm

bikewithnoname View the latest post

There are no new unread posts for this topic. Mounting Rotor QX1 to Race Face Next SL crank

in MTB

mtbstuff

10

905

Sat Nov 01, 2014 4:31 am

dwaharvey View the latest post

There are no new unread posts for this topic. 9070 di2 problems

in Road

dane476

7

970

Fri Oct 10, 2014 2:55 pm

Briscoelab View the latest post


It is currently Sat May 23, 2015 5:27 pm

All times are UTC + 1 hour




Advertising   –  FAQ   –  Contact   –  Convert   –  About

© Weight Weenies 2000-2013
hosted by starbike.com


How to get rid of these ads? Just register!


Powered by phpBB